links in rss feed are bad; missing update type

RESOLVED FIXED in 1.1

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: daneel, Assigned: alanjstr)

Tracking

unspecified

Details

(Whiteboard: landme, URL)

Attachments

(1 attachment, 4 obsolete attachments)

1.96 KB, patch
morgamic
: first-review+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

the links look like this:
http://addons.update.mozilla.org//moreinfo.php?id=431&vid=1408

notice the double slash after the domain.  it looks like it is missing the
update type ("extension", "theme", etc.).  the links on the web page
http://addons.update.mozilla.org/ are fine.  just fix the rss feed.

Reproducible: Always

Steps to Reproduce:
1. go to http://addons.update.mozilla.org/
2. add the rss feed listed on the page to your news reader
3. refresh the feed from your news reader
4. click on one of the updates

Actual Results:  
you get sent to a "Not Found" error ("The requested URL /moreinfo.php was not
found on this server...") screen.

Expected Results:  
launched the page where i can download the update that i clicked on from my news
reader.
(Assignee)

Comment 1

14 years ago
Has this ever worked when type isn't provided?  The only version I see in LXR
requires typeName and the SQL query doesn't even pull type from the resultset. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Has this ever worked when type isn't provided?  The only version I see in LXR
> requires typeName and the SQL query doesn't even pull type from the resultset. 

I think type is provided with the record, it's just not showing up in the URL. 
For example, an item in the rss feed contains a <link> node with a value of:

http://addons.update.mozilla.org//moreinfo.php?id=431&vid=1408

...but the link should be:

http://addons.update.mozilla.org/extensions/moreinfo.php?id=431&vid=1408
(Assignee)

Comment 3

14 years ago
Reassigning to default assignee
Assignee: bugtrap → Bugzilla-alanjstrBugs
(Assignee)

Updated

14 years ago
Target Milestone: 1.0 → 1.1
(Assignee)

Comment 4

14 years ago
Created attachment 172127 [details] [diff] [review]
Pull in Main.type and reuse code

Yes, I know you hate it when I do both at the same time.  This patch is for
trunk.	Branch will be more simple.
Attachment #172127 - Flags: first-review?(cst)
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

14 years ago
I don't have a copy of branch.  Here's the changes required.

rss/index.php:
$select = "SELECT DISTINCT 
main.ID, 
main.Name AS Title, 
main.Type,

rss/inc_rssfeed.php:
$types = array("E"=>"Extensions","T"=>"Themes","U"=>"Updates","P"=>"Plugins");
$listType = $types["$type"];

$itemtype = $row["Type"];

echo "      <link>http://$sitehostname/" . types["i$itemtype"].
"/moreinfo.php?id=" . $id . "&amp;vid=" . $vid . "</link>\n";

Comment on attachment 172127 [details] [diff] [review]
Pull in Main.type and reuse code

://$sitehostname/" . types["i$itemtype"]. "/moreinfo.php?id=" . $id .
"&amp;vid=" . $vid . "</link>\n";

i$itemtype?

+//echo "<!-- $sql --";
Fix that please

the rest looks ok.
Attachment #172127 - Flags: first-review?(cst) → first-review-
(Assignee)

Comment 7

14 years ago
Created attachment 172143 [details] [diff] [review]
nits fixed
Attachment #172127 - Attachment is obsolete: true
Attachment #172143 - Flags: first-review?(cst)
Attachment #172143 - Flags: first-review?(cst) → first-review+
(Assignee)

Updated

14 years ago
Whiteboard: landme
(Assignee)

Comment 8

14 years ago
Created attachment 172193 [details] [diff] [review]
Diff for branch
Attachment #172193 - Flags: first-review?(cst)
Comment on attachment 172193 [details] [diff] [review]
Diff for branch

+ maint.Type,

shouldn't that be "main.Type,"?
Attachment #172193 - Flags: first-review?(cst) → first-review-
(Assignee)

Comment 10

14 years ago
Created attachment 172624 [details] [diff] [review]
removed t
Attachment #172193 - Attachment is obsolete: true
Attachment #172624 - Flags: first-review+
(Assignee)

Comment 11

14 years ago
r=CTho
(Assignee)

Comment 13

13 years ago
*** Bug 287673 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
I've just seen this bug mentioned in #umo, but the patch won't apply ATM. New
patch coming up shortly.

Comment 15

13 years ago
Created attachment 181071 [details] [diff] [review]
Unbitrotted Patch

Unbit rot patch and add WEB_PATH to the URL.

Demo at
https://update-staging.mozilla.org/~colin/update/rss/?application=firefox&list=newest
Attachment #181071 - Flags: first-review?(mike.morgan)
Attachment #181071 - Flags: first-review?(mike.morgan) → first-review+
Landed - will be pushed on next update.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Attachment #172624 - Attachment is obsolete: true
Attachment #172143 - Attachment is obsolete: true
(Assignee)

Comment 17

13 years ago
*** Bug 291387 has been marked as a duplicate of this bug. ***

Comment 18

13 years ago
*** Bug 291637 has been marked as a duplicate of this bug. ***

Comment 19

13 years ago
*** Bug 291892 has been marked as a duplicate of this bug. ***

Comment 20

13 years ago
Well, sorry for submitting a dupe, but when I search for "rss" on the Update
component when preparing to submit a new bug, this one doesn't come up.  :/
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.