User Agent in browser preference bar defaults to "Real UA" every time

RESOLVED INVALID

Status

--
enhancement
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: beitmanh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 1.85a, 1.84 also

No matter how many times I change the preference bar selection to something
else, ie. Mozilla or IE, the next time Mozilla starts it defaults to Real UA. 
Shouldn't this be configured as the user pleases?  Many sites require IE and I
find if I just set it to IE it solves most problems.

Reproducible: Always

Steps to Reproduce:
1. Load Mozilla
2. Change user agent to something other than "Real UA"
3. Exit Mozilla
4. Load Mozilla


Actual Results:  
5. UA is back to "Real UA"

Expected Results:  
It should keep the UA selected by the user, or, better yet, it should let you
chose if i keeps the UA or defaults to "Real UA."  Perhaps a "defualt to" choice
should be given?

This is not a big problem, but it is frustrating to repeadedly go to sites that
look for IE and have to manually change the UA every time.
this is not a mozilla bug, but an issue in the prefbar extension; do note that
this may well be done on purpose since the java plugin prevents starting mozilla
if the user agent is set to msie.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.