xpidl segfaults when compiling mozilla 1.7.3 / Assertion failed: state->tree, file xpidl_idl.c, line 60

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Pavel Zubkov, Unassigned)

Tracking

1.7 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
xpidl segfaults when I compile mozilla1.7.3 --disable-debug, it also segfaults
when I run it as "xpidl -m header"

# dist/bin/xpidl -m header
ERROR: extra arguments after input file
Segmentation fault

when I compile mozilla with enabled debuging I get error in place where before
xpidl segfaults

nsIConsoleListener.idl
../../dist/bin/xpidl -m header -w -I. -I../../dist/idl -o
_xpidlgen/nsIConsoleListener nsIConsoleListener.idl
Assertion failed: state->tree, file xpidl_idl.c, line 60
make[3]: *** [_xpidlgen/nsIConsoleListener.h] Aborted

configure command:
./configure --prefix=/usr \
            --with-default-mozilla-five-home=/usr/lib/mozilla \
            --with-system-zlib \
            --with-system-png \
            --enable-application=suite \
            --enable-default-toolkit=gtk2 \
            --enable-extensions=all \
            --enable-crypto \
            --enable-xft \
            --enable-xinerama \
            --enable-optimize \
            --enable-reorder \
            --enable-strip \
            --enable-cpp-rtti \
            --enable-calendar \
            --disable-freetype2 \
            --disable-accessibility \
            --disable-debug \
            --disable-tests \
            --disable-logging \
            --disable-pedantic \
            --disable-installer
hm... there's bug 107250 about that assertion but it's WORKSFORME...
Summary: xpidl segfaults when compiling mozilla 1.7.3 → xpidl segfaults when compiling mozilla 1.7.3 / Assertion failed: state->tree, file xpidl_idl.c, line 60

Comment 2

13 years ago
is there anything unusual about your system?  what gcc version are you using?
(Reporter)

Comment 3

13 years ago
>is there anything unusual about your system?
now I can't reproduce this error, but early I have two versions of libIDL (old
0.6 branch & new 0.8 branch). configure detects and use new 0.8.x version, but
compilation failed. after uninstalling 0.6.x all works fine.

>what gcc version are you using?
hm... I think it's gcc-3.4.1 or 3.4.3...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.