Closed Bug 278468 Opened 15 years ago Closed 15 years ago

'open in tabs' kills existing tabs

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 216346

People

(Reporter: mozilla, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050114 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050114 Firefox/1.0+

The 'Open in tabs' option is really handy for opening several bookmarks at once.
However, it seems to always reuse whatever tabs you have open, therefor loosing
the currently-open tab. I think it would be much better if 'open in tabs' would
always open new tabs, instead of re-using the tabs you currently have open. This
is related to a comment made in bug 227388, but is not a direct dup of the issue
reported in that bug, so I'm making a new one.

Reproducible: Always

Steps to Reproduce:
1. Open at least two tabs
2. Open bookmarks, and click 'open in tabs' on the bookmarks
3. See how Firefox opens your bookmarks in your existing tabs, losing whatever
tabs you had open.

Actual Results:  
Firefox closed currently-open tabs, and then opened new ones with my bookmarks.

Expected Results:  
Left my existing tabs alone, and opened a new one for each bookmark.
By design. See bug 244871 comment 1.

*** This bug has been marked as a duplicate of 244871 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.