Firefox 1.0+ search failure when Ablock filters certain sites

RESOLVED DUPLICATE of bug 274553

Status

()

--
major
RESOLVED DUPLICATE of bug 274553
14 years ago
14 years ago

People

(Reporter: fehe, Assigned: bugzilla)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Some sites filtered when Adblock is used in combination with a Firefox 1.0+
trunk build are no longer searchable.

To Reproduce:

1. Uninstall your previous version of Mozilla Firefox
2. If you did not delete the Firefox directory with Step 1, delete all content
in the directory, with the exception of the plugins directory
3. Install a Firefox 1.0+ January trunk build (exe or zip distribution)
4. Launch Firefox and install Adblock v.5 d2 nightly 39 from
http://adblock.mozdev.org/dev.html and restart Firefox
5. Import into Adblock the filter list attached to this bug report
6. Go to http://club.cdfreaks.com/lite/f-57-p-2.html
7. To perform a search, type: /problem
8. Notice that search did not work - even though the word "problem" is present
in multiple places on the website.  Not even Edit --> "Find in This Page..." works.
9. Disable Adblock and close Firefox
10. Launch Firefox and go to http://club.cdfreaks.com/lite/f-57-p-2.html
11. No perform the search again by typing: /problem
12. The search should now have worked. What gives?

*** This bug has been marked as a duplicate of 274553 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
Created attachment 171319 [details]
Adblock filters for testing the bug
You need to log in before you can comment on or make changes to this bug.