<xml> tags are not supported

VERIFIED DUPLICATE of bug 31331

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 31331
13 years ago
13 years ago

People

(Reporter: fafey Song, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-CN; rv:1.7.5) Gecko/20041124 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-CN; rv:1.7.5) Gecko/20041124 Firefox/1.0

although it is just from microsoft, there are some website developers who likes
to use it, and I think it is not difficult to support it.

Reproducible: Always

Steps to Reproduce:
1.display the page
2.
3.

Actual Results:  
my firefox just write down the content of every node between <xml> and </xml>

Comment 1

13 years ago
The page linked to has no DOCTYPE declaration, just a text/html META tag, so
Firefox is (correctly, IMO) assuming that it's an old-style HTML page. HTML
requires that any unrecognized tags are ignored, for compatibility reasons. I
don't really see what else FF could reasonably do in this situation.

If you want to embed XML in a webpage, you should be using XHTML.

Comment 2

13 years ago
Your page starts

<META content="text/html; charset=gb2312" http-equiv=Content-Type>
<title>My MPC-&#26292;&#39118;&#24433;&#38899; 5.00 &#36719;&#20214;&#19979;&#36733;-&#22826;&#24179;&#27915;&#19979;&#36733;&#20013;&#24515;</title>
<meta name="keywords" content="My MPC-&#26292;&#39118;&#24433;&#38899; 5.00 &#36719;&#20214;&#19979;&#36733;-&#22826;&#24179;&#27915;&#19979;&#36733;&#20013;&#24515;">
<meta name="description" content="&#20316;&#20026;&#23545; Windows Media Player &#30340;&#34917;&#20805;&#21644;&#23436;&#21892;&#65292;My
MPC &#31995;&#21015;·&#26292;&#39118;&#24433;&#38899;&#25552;&#20379;&#21644;&#21319;&#32423;&#20102;&#31995;&#32479;&#23545;&#24120;&#35265;&#32477;&#22823;&#22810;&#25968;&#24433;&#38899;&#25991;&#20214;&#21644;&#27969;&#30340;&#25903;&#25345;&#12290;">
  <xml id=xmlDLInfo>

and I suspect that the problem starts with the fact that you are sending 
xml but claiming the type to be text/html. If you want Mozilla to process 
xml then you need (at the least) to specify an appropriate mime type.
Heh. Give us three people passing by, and you'll get one that knows what you mean.

For the benefit of anyone else who winds up here and confused, the reporter is
talking about Microsoft's proprietary "XML Data Islands" where you just enclose
any arbitrary XML you want inside <xml id="foo">...</xml> and then script
against their XML DOM with foo.XMLDocument.documentElement.childNodes.item(1).text

Sorry, not going to happen beyond what exists already: if you don't use things
that have the same names as HTML elements, and you don't use <foo/>, and you are
careful about how you access the DOM, it's possible to do it right now, just
relying on our error handling and our treating the XML as unknown HTML. But a
full completely compatible with IE's "XML Data Islands" implementation that
would work with pconline.com.cn just isn't possible: it would involve completely
rewriting the HTML parser, and completely reverse-engineering IE's
implementation, since it isn't documented in the way another implementer would
need it to be. I can imagine it happening if some big company (probably some big
Asian company, since XML Data Islands seem much more popular there than in the
rest of the world) decided to throw lots of people and money at it, so that the
current volunteer programmers only had to object, and object again, until all
their objections were met, but I can't imagine that they will all voluntarily
stop working on anything else and completely rebuild the parser to work with a
proprietary Microsoft invention.

*** This bug has been marked as a duplicate of 31331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.