Select list content rendered outside select list frame when floated inside span.

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
14 years ago
4 years ago

People

(Reporter: Keith Maika, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041130

When you have a < select multiple> listbox with a style of 'float: left'; which
is wrapped inside of a span tag, the contents of the select box are rendered
outside the frame of select box.  See the URL for a small testcase.


Reproducible: Always

Steps to Reproduce:
1. Put a multiple select box inside of a span element, and some nearby text
outside that span.
2. Give the select box a style of 'float: left';


Actual Results:  
The contents of the select box is rendered outside the frame for the select box.

Expected Results:  
The selectbox should never be split between it's content and it's frame.

Removing the span or adding 'float: left' to the span as well appears to fix the
problem, however it is my opinion that a select box should never be able to
split like this.
(Reporter)

Comment 1

14 years ago
Created attachment 171346 [details]
Minimal test case.

Here is a minimal testcase demonstrating the problem.
(Reporter)

Comment 2

14 years ago
Created attachment 171347 [details]
Screenshot of the problem.

Screenshot of what I see.

Comment 3

14 years ago
I see this with linux build 1.7.5, but worksforme with linux trunk 2005011505. 
can you try a trunk build (1.8a6)?
Whiteboard: DUPEME

Comment 4

14 years ago
Bug seen: 
Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

working:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20050108 Firefox/1.0+
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b) Gecko/20050116

So the problem is on Windows and Linux, isn´t in the trunk, but maybe in the
branch, if not fixed in the meantime.
(Reporter)

Comment 5

14 years ago
I just tried using the 1.8 source and it worked ok.  The scrollbar seemd a bit
strange, but nothing was wrong so to speak.  The scrollbar was just very dark
until there were actuall items to scroll to.

Comment 6

14 years ago
ok, so this a dupe of an unknown bug that's been fixed since 1.7, but resolving
WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.