Closed Bug 278530 Opened 17 years ago Closed 15 years ago

Chinese Character File Name Save Error

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 359148

People

(Reporter: valensc, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Chinese Character file name writing error in download manager.

Reproducible: Always

Steps to Reproduce:
1. in FireFox Browser, right click to save a photo
2. Photo file name contains Chinese Characters
3. File name shows up in the destination selection popup window
4. File ends up save as "_" per chinese character. E.G. 3 characters.jpg ends up
___.jpg



Expected Results:  
File name should be the same as user wanted.
I am getting this problem consistently with Russian (Cyrillic) symbols in the
filename. IE handles them just fine, while FireFox 1.0.4 on Windows 2000 shows
the proper filename in the Save As dialog, but uses underscores when saving the
file. Also if I download the same file it doesn't prompt to overwrite it either.
Summary: Chinese Character File Name Save Error → Chinese Character File Name Save Error
Confirmed with Greek characters in file name.  Firefox 1.5.0.4 on Windows XP Pro.
This bug appears similar in nature to Bug 234681, which has to do with saving attachments from email messages in Mozilla Suite and Thunderbird.
QA Contact: ali → download.manager
Assignee: bugs → nobody
WFM with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a5pre) Gecko/20070528 Minefield/3.0a5pre (pretty obviously)
it seems like a dupe of Bug 359148

Bug 234681 is about Attachments, see also https://bugzilla.mozilla.org/show_bug.cgi?id=234681#c11
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 359148
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.