table-layout:fixed rendering incorrect. Resizing screen results in the expected rendering.

RESOLVED DUPLICATE of bug 178762

Status

()

RESOLVED DUPLICATE of bug 178762
14 years ago
5 years ago

People

(Reporter: robinpelgrim, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The following example shows the problem. The table-height should be 100%. This
is only rendered correctly after the browser window is resized!
Why is HTML-rendering ALWAYS such a mess? ==>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd"> 
<HTML style="width:100%;height:100%">
	<HEAD>
		<TITLE>Bug! Resize browser window! Viva HTML :(</TITLE>
	</HEAD>
	
	<BODY style="width:100%;height:100%">
		<TABLE cellspacing="0px" style="table-layout:fixed;width:100%;height:100%;">
			<TR style="height:100%">
				<TD height="100%">
					<IFRAME style="height:100%;background-color:blue">
					</IFRAME>
				</TD>
			</TR>
		</TABLE>	
	</BODY>
	
</HTML> 

Reproducible: Always

Steps to Reproduce:
1. Just open the HTML example
2.
3.



Expected Results:  
Render as expected.
I've seen this bug somewhere before, so probably a duplicate.

Comment 2

14 years ago
Please create a testcase and upload it in a normal manner.
Your webpage (strict definition) triggers standards compliant rendering mode.

I don't see how the declaration table-layout: fixed has anything to do with the
rendering of the page. Note the iframe in your testcase has no src attribute, is
not loading any url: all it should render is an empty node.

There are already 8 bugfiles with the words table, iframe and height in the
summary and already 46 bugfiles with the words iframe and height. So, there must
be a duplicate for this if this bug is valid.
Whiteboard: DUPEME

Comment 3

14 years ago
>I've seen this bug somewhere before, so probably a duplicate.
ehm, Martijn you wrote the testcase

*** This bug has been marked as a duplicate of 178762 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
>Why is HTML-rendering ALWAYS such a mess?

Because YOU did not fix it. 

The problem here is that for the fixed layout one height reflow is not issued.
Resizing gives the necessary reflow, the short workaround is probably to remove
the fixed layout, on the long way it would be cool if you could go and fix it.
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> >Why is HTML-rendering ALWAYS such a mess?
> 
> Because YOU did not fix it. 
> 
> The problem here is that for the fixed layout one height reflow is not issued.
> Resizing gives the necessary reflow, the short workaround is probably to remove
> the fixed layout, on the long way it would be cool if you could go and fix it.

window.document.body.style.height = "99%";
window.document.body.style.height = "100%";

is, for now, my workaround.

Perhaps I will fix it, on the long way, but there are so many other things to do
(and fix)... 

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.