Only half of the flash animation is shown

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: OmarChavez85023, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

There is a flash animation that is supposed to be shown at ford.svt.com, and it
does not, it only appears the bottom half, the top half, has been cut off.

Reproducible: Always

Steps to Reproduce:
1.open firefox
2.go to site:(www.svt.ford.com)
3.see theat only half of the flash animation is viwed, the bottom half is shown,
top half isnt

Actual Results:  
i only saw the bottom half of the animation

Expected Results:  
shown the full animation

Comment 1

14 years ago
See Bug 278631 "jeanmicheljarre.com - can't see the whole page, flash contents
is clipped at the top"

Updated

14 years ago
Summary: Only half of the flash animaion is shown → Only half of the flash animation is shown
Version: unspecified → 1.0 Branch

Comment 2

13 years ago
duplicate of #289922

Comment 3

13 years ago
Hello,
I have the same problem with a Flash site I produced - so I know what is going on. 

Go to http://www.gingerman.co.uk/itssolved/index.html

The top of the animation is viewable and the bottom half cuts off completely.

Flash is not the culprit - I have checked this in Safari, IE and Firefox, and
also on Mac and PC. Firefox fails on both Mac and PC.
The Flash plugin 7 an 8 have been tested and they only fail in Firefox.

What flash is doing - it detects the size of the movie - which is changed
initially by some javascript to fill the screen.
When the movie detects that change it resizes the Flash Movie in the page and
scales up a 1 pixel wide jpg of the gradient in the background so it fills the
screen on the width.
Also the main graphic area is centred, whether it be the preloader which is
updated every 10ms on an interval and uses the drawing API to draw it, or whther
it be the main site which listens for a stage size change and then does some
simple maths and centres itself accordongly.

This is such an odd bug, but if someone needs my code to check things then
please get in touch.

Regards

Stephen Matthews

Comment 4

13 years ago
Hello,
I have the same problem with a Flash site I produced - so I know what is going on. 

Go to http://www.gingerman.co.uk/itssolved/index.html

The top of the animation is viewable and the bottom half cuts off completely.

Flash is not the culprit - I have checked this in Safari, IE and Firefox, and
also on Mac and PC. Firefox fails on both Mac and PC.
The Flash plugin 7 an 8 have been tested and they only fail in Firefox.

What flash is doing - it detects the size of the movie - which is changed
initially by some javascript to fill the screen.
When the movie detects that change it resizes the Flash Movie in the page and
scales up a 1 pixel wide jpg of the gradient in the background so it fills the
screen on the width.
Also the main graphic area is centred, whether it be the preloader which is
updated every 10ms on an interval and uses the drawing API to draw it, or whther
it be the main site which listens for a stage size change and then does some
simple maths and centres itself accordongly.

This is such an odd bug, but if someone needs my code to check things then
please get in touch.

Regards

Stephen Matthews

Comment 5

13 years ago
The same happens on:
http://www.gigabyte.com.tw/

Comment 6

13 years ago
*** Bug 250830 has been marked as a duplicate of this bug. ***
Assignee: bross2 → nobody
I can't reproduce using any of the URIs in this bug in Firefox 2.0.0.3 on Windows XP. If you're still seeing this bug using Firefox 2.0.0.3 or later with a new profile, please file a new bug detailing exactly what site you see this on.

http://kb.mozillazine.org/Profile_Manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.