Enhancement: auto-respond, auto-forward need to be available in message filters

VERIFIED DUPLICATE of bug 11034

Status

--
enhancement
VERIFIED DUPLICATE of bug 11034
14 years ago
14 years ago

People

(Reporter: Ashnan_Etana, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla Thunderbird 1.0 (20041206)

Desired Result:
I would like to be able to auto-respond and auto-forward to ALL emails that I
receive. It would be useful when away from home/office for an extended period of
time.

Current Issue Prohibiting Desired Result:
1) There is currently no way to apply filter to ALL incoming emails.
2) Current message filters do not have the option of generating an auto-response
to the sender.
3) Message filters do not have the option of automatically forwarding an
incoming message to another email address.
4) Message filters also need to have a way to 'stop processing' further filters
on the message once it has been identified and acted upon by a previous filter. 

Reproducible: Always

Steps to Reproduce:
1. Tools>Message Filters>New
2. No choice of "For All Messages" to perform action on.
3. No choice of "auto response" to perform.
4. No choice of "forward incoming email to" to perform.
5. No way to "stop processing" further filters on identified and processed emails.

Actual Results:  
No choices available.

Expected Results:  
Incoming email received.
Automatically replies to sender with an "out of office" message.
Automatically forwards received email to another address.
Stops processing filters after this has been completed.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 11034 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.