Missing } in JavaScript function causes crash (M13)

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
P3
critical
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: Chad Daelhousen, Assigned: Mike McCabe)

Tracking

({crash})

Trunk
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
There was a missing } at the end of function ir(img, index, on_switch).  Both 
commenting out the entire function and adding the necessary } let the page 
display.  NS 4.7 did not crash.  A dump of the mozilla debug window is available 
through e-mail.  Here are the next few statements it tried to execute in the 
buggy script:
----in function (one { deep)----
//-->
</SCRIPT>
</HEAD>
<BODY bgcolor="#ffffff" link="#003366" 
onLoad="pi();if(window.pup!=null)Pup();"><NOSCRIPT>          
You are receiving this message because you need to <a 
href="http://home.netscape.com/computing/download/index.html">upgrade your 
browser</a> or have <a 
href="http://shareware.netscape.com/computing/shareware/enable_js.tmpl?p=PC">dis
abled JavaScript</a>.
</NOSCRIPT>
----end----
(Assignee)

Comment 1

19 years ago
loonthetall -

Could you please save the problem page and add it to this bug report as an
attachment?  Sounds like a good testcase.
(Reporter)

Comment 2

18 years ago
Created attachment 5342 [details]
home.netscape.com HTML source on 15 Feb 2000
(Reporter)

Comment 3

18 years ago
Once the } is added to the ir function, the page displays very crazily but does 
not crash mozilla.  Displays correctly either way in NN4.7.
(Assignee)

Comment 4

18 years ago
I can't pick up the attachment; I get 'h.js was not found on this server'.

Is there any chance you could cook the code from the netscape home page into the
simplest possible case that still demonstrates the problem?  I may end up
passing this off to the HTML parsing guys, and it'd be a great help to them.

Thanks -
Mike
(Reporter)

Comment 5

18 years ago
I can't reproduce the bug, even by setting the date back to Tuesday... what's 
more, broken images are now displaying fist as a broken image, then a moment 
later as the name from the <IMG SRC> attribute, even after rebooting.  They 
displayed fine (the rectangle with the little page-with-an-X icon) before I 
started playing with this bug.
<IMG SRC="anythingyouwant"> causes the word anythingyouwant to appear as 
selectable text.  Extensions are not displayed.  This happens locally and 
remotely.  A test case is at http://thesapphirecat.iwarp.com/hnc-tst2.html - 
"viashino" is the IMG SRC.
Since I have no idea what to call this bug now, I am leaving the summary alone.

Comment 6

18 years ago
Adding crash keyword.
Keywords: crash

Comment 7

18 years ago
can't reproduce this in 60208 win ME. marking wfm, pls reopen if you're still 
seeing this
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 8

18 years ago
Verified 2000092908
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.