Hook up schema validation to xforms submission

RESOLVED WONTFIX

Status

Core Graveyard
XForms
RESOLVED WONTFIX
13 years ago
a year ago

People

(Reporter: Darin Fisher, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.17 KB, application/xhtml+xml
Details
(Reporter)

Description

13 years ago
Hook up schema validation to xforms submission
(Reporter)

Updated

13 years ago
Depends on: 274083

Updated

12 years ago
Blocks: 326372

Updated

12 years ago
Blocks: 326373

Updated

12 years ago
Whiteboard: [good first bug]

Updated

12 years ago
Blocks: 331209

Comment 1

11 years ago
I'm not 100% sure that this is a "[good first bug]". The submission handling needs to be restructured. Right now there are different code paths for turning instance data into a submit. We need to unify that to:
1) everything is serialized into an XML document
2) all non-relevant nodes are pruned
3) the XML document is fed to schema validation
4) the specific serialization method is run

Comment 2

11 years ago
Created attachment 222347 [details]
Testcase

Have the testcase right Doron?

Comment 3

11 years ago
(In reply to comment #2)
> Created an attachment (id=222347) [edit]
> Testcase
> 
> Have the testcase right Doron?
> 

Free "I got"'s handed out at the exit.

Comment 4

11 years ago
I'll look at it
Assignee: aaronr → allan

Comment 5

11 years ago
Should be fairly easy to fix bug 338314, while doing this as this should streamline the serialization process in general anyways.
Blocks: 338314
Status: NEW → ASSIGNED

Comment 6

11 years ago
As a result of bug 338314, it should be fairly easy to add this now. nsXFormsSubmissionElement::Submit() just needs to validate the document.

The problem is that I am not sure what to do, because I just ran through the spec., and there is not mention of what I thought we were supposed to do here.

"2. All selected instance data nodes are checked for validity according to the definition in 4.3.5 The xforms-revalidate Event (no notification events are marked for dispatching due to this operation). Any selected instance data node that is required but empty or found to be invalid stops submission processing after dispatching event xforms-submit-error."
[http://www.w3.org/TR/2006/REC-xforms-20060314/slice11.html#submit-event]

Eh? I was expecting to see something about "perform full schema validation", because that is what I have always thought was supposed to happen.

http://lists.w3.org/Archives/Public/www-forms/2006May/0144.html
Assignee: allan → aaronr
Status: ASSIGNED → NEW

Comment 7

11 years ago
Since it is not clear what this actually means, it will miss 0.6
No longer blocks: 331209
Whiteboard: [good first bug]

Comment 8

11 years ago
Yeah, I think we need to get this all clarified.  Because we also need to know what to do if the value of a node is perfectly valid but what if the document that contains it is invalid (the instance node isn't in the right place in the document relative to another node, for example, or is missing an attribute).  The spec doesn't seem to differentiate between validating the value of an instance node and validaing the node itself.

Updated

11 years ago
Assignee: aaronr → xforms
RIP xforms
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.