layout gets messed up (moves up by a few pixels) when clicking on one of the buttons

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Matthew Darwin, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050117 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050117 Firefox/1.0+

You need to enable popups and Java for this site.

After the toolbar loads, you will see that the layout of the toolbar looks very
nice.  Click on one of the buttons.  Notice that the row of buttons moves up
several pixels.  As you click on the buttons, notice that the highlight effect
that is drawn around an element that is selected is actually drawn where the
buttons should be and not where they actually are.

This bug is not reproducible in Firefox 1.0... you need a more recent build.

Reproducible: Always

Steps to Reproduce:
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

13 years ago
Tested in Firefox 1.0.6, although it was resolved in an earlier release.

Confirmed as Fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 3

13 years ago
No changes were made to the code base by this bug, worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

13 years ago
Code changes were definately made to resolve this issue.  It was all around 
management of size of windows opened by window.open().  There was discussion
in other related bugs.

Comment 5

13 years ago
We don't know what code changes fixed this, this is a duplicate of some bug but
it is far too much work to find the bug to dupe this to. 

Fixed is only for bugs that we can point to the code/patch that changed to fix the
bug. Worksforme covers things that just start working in current nightlies.
You need to log in before you can comment on or make changes to this bug.