Crash FFTrunk [@ 0xffffff4d - js_GC]

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: Pavel Penaz, Assigned: Blake Ross)

Tracking

({crash, topcrash})

Trunk
x86
Windows XP
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050117 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050117 Firefox/1.0+

Last week my Firefox started crashing regularly. This crash occurs rather
randomly, I hope the talkback IDs will suffice to track the cause of this issue.

Some TalkBack IDs:

TB3125616X
TB3121028Z
TB3104307
TB3097096

Reproducible: Couldn't Reproduce

Steps to Reproduce:
All the talkbacks contain js3250.dll. Marking in summary.

0xffffff4d
0x013a1008
js3250.dll + 0x1c121 (0x6009c121)
js3250.dll + 0x1bbc8 (0x6009bbc8)
Summary: Crash Firefox Trunk → Crash Firefox Trunk [ @ js3250.dll ]

Comment 2

14 years ago
Builds from 1/17 did not have symbols, therefore the stack signatures and traces
were not resolved to the proper function names.  If you are still able to
reproduce this crash, please do so with a recent nightly and report back with
new Talkback info.  

You can look up your incidents at http://talkback-public.mozilla.org to see if
the stacks look more useful than the one already posted here.  Thanks.
Keywords: crash
Summary: Crash Firefox Trunk [ @ js3250.dll ] → Crash FFTrunk [ @ js3250.dll ]

Comment 3

14 years ago
Here is a quick query for all "0xffffff4d" crashes since the beginning of the year:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=0xffffff4d&vendor=All&product=All&platform=All&buildid=2005&sdate=&stime=&edate=&etime=&sortby=bbid

This also seems to be a topcrash on the MozillaTrunk, and the stacks vary, but I
see a log of js_GC stuff there, so they might be related.

Here is one incident I found on the FFTrunk that had a full stack trace:
Incident ID: 3224774
Stack Signature	0xffffff4d fd18c64c
Product ID	FirefoxTrunk
Build ID	2005011606
Trigger Time	2005-01-22 12:43:57.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	
URL visited	http://www.ebay.com
User Comments	Browsing plastic/rubber bracelets. (cancer support, tsunami
support, aids support etc)
Since Last Crash	3186 sec
Total Uptime	22757 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
0xffffff4d
0x01270008
js_GC  [c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/js/src/jsgc.c,
line 1764]
js_ForceGC 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/js/src/jsgc.c, line 1463]
nsEventListenerManager::HandleEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1596]
nsXULElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2177]
nsXULElement::HandleChromeEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 3247]
nsGlobalWindow::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 928]
nsDocument::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsDocument.cpp,
line 3837]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2028]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsHTMLFormElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/html/content/src/nsHTMLFormElement.cpp,
line 698]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
nsGenericElement::HandleDOMEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2020]
PresShell::HandleEventInternal 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/layout/base/nsPresShell.cpp,
line 5917]
PresShell::HandleEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/layout/base/nsPresShell.cpp,
line 5773]
nsViewManager::HandleEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 2408]
nsViewManager::DispatchEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 2133]
HandleEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/view/src/nsView.cpp, line
174]
nsWindow::DispatchEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1103]
nsWindow::DispatchMouseEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 5393]
ChildWindow::DispatchMouseEvent 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 5644]
nsWindow::WindowProc 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1389]
USER32.dll + 0x8709 (0x77d48709)
USER32.dll + 0x87eb (0x77d487eb)
USER32.dll + 0x89a5 (0x77d489a5)
USER32.dll + 0x89e8 (0x77d489e8)
nsAppShell::Run 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp,
line 159]
nsAppStartup::Run 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/toolkit/components/startup/src/nsAppStartup.cpp,
line 147]
main 
[c:/builds/tinderbox/firefox/WINNT_5.0_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 60]
kernel32.dll + 0x16d4f (0x7c816d4f)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Crash FFTrunk [ @ js3250.dll ] → Crash FFTrunk [ @ 0xffffff4d - js3250.dll ]

Updated

14 years ago
Keywords: topcrash
Summary: Crash FFTrunk [ @ 0xffffff4d - js3250.dll ] → Crash FFTrunk [@ 0xffffff4d - js_GC]
(Reporter)

Comment 4

13 years ago
I will mark this bug WFM because according to talkbacks this crash no longer
occurs in recent builds. Feel free to reopen this bug..
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ 0xffffff4d - js_GC]
You need to log in before you can comment on or make changes to this bug.