Alt+letter does not pull down menu, it opens a dialog

VERIFIED FIXED in M14

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Ninoschka Baca, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] fix in hand. approval anyone?)

(Reporter)

Description

19 years ago
Build 2000-02-14-16M14: NT4

I am reporting this bug on Mail/Composer because Alt+letter keys in other 
components do work such as the Editor and the Address Book. 

Overview: Access the Mail/Composer top level menu by using the Alt+letter 
sequence (i.e. Alt+F for the File menu to appear), instead a dialog appears or 
nothing happens.

Steps to reproduce:
1. In the 3-pane select the "New Msg" button for Composer to appear
2. Place the cursor on any section of the Composer window
3. Type "Alt+F", (disable the dialog if one appears)
4. Type "Alt+I", (disable the dialog if one appears)
5. Type "Alt+O"

Actual Results: 
- After step#3 notice an "Enter file to attach" dialog appears. I also noticed 
that the File|Attach (F)ile mnemonic is an "F". Since the top level "File" and 
"Attach File" are using the same mnemonic, maybe this is causing a conflict?

- After step#4 notice that an "Image Properties" dialog appears. I also noticed 
that the "Insert|(I)mage..." mnemonic is an "I". Again, the top level "Insert" 
and "Image" are using the same mnemonic.

- After Step# 5 notice that nothing happens. It should open the Format menu.

Expected Results:
- Alt+F should open the File menu
- Alt+I should open the Insert menu
- Alt+O should open the Format menu

Additional Information:
- Alt+E opens the Edit menu as expected.
(Reporter)

Updated

19 years ago
Keywords: beta1
QA Contact: lchiang → nbaca

Comment 1

19 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]
Menu navigation problem, reassign to trudelle.
Assignee: ducarroz → trudelle

Comment 3

19 years ago
Can't get at my PC right now, cc saari until I can reproduce this.

Updated

19 years ago
Assignee: trudelle → saari

Comment 4

19 years ago
Not only does the dialog come up, the menus start behaving as if they had
received a mousedown - they drop down on mere mouseover. reassigning to saari as
p2 for M14. cc pinkerton & hyatt.
(Assignee)

Comment 5

19 years ago
Sounds like someone defined some bad key bindings to me.  Probably a bug in the 
mailcompose key bindings and not in XPToolkit infrastructure.

Updated

19 years ago
Target Milestone: M14

Comment 6

19 years ago
I just grepped all the xul for an alt+F binding and didn't find one.

Sorry Dave, looks like your recent changes...
Assignee: saari → hyatt
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: [PDT+] → [PDT+] fix in hand. approval anyone?
(Assignee)

Comment 7

19 years ago
fixed
]
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

19 years ago
Build 2000-02-22-16M14: NT4
Verified Fixed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

19 years ago
*** Bug 24071 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.