Doesn't handle 32-bit IMAP uid

RESOLVED DUPLICATE of bug 277905

Status

--
critical
RESOLVED DUPLICATE of bug 277905
14 years ago
14 years ago

People

(Reporter: michael, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

If the IMAP server returns a message UID that is greater than 2^31, then 
thunderbird/mozilla incorrectly clamps the value to 0x7fffffff

The IMAP RFC specifies that the UID is a 32-bit value, but thunderbird
incorrectly treats it as a signed value rather than an unsigned value.

Reproducible: Always

Steps to Reproduce:
Example strace:

26216 write(1, "* FLAGS (\\Answered \\Flagged \\Deleted \\Seen \\Draft)\r\n* OK
[PERMANENTFLAGS (\\Answered \\Flagged \\Deleted \\Seen \\Draft \\*)] Flags
permitted.\r\n* 1 EXISTS\r\n* 1 RECENT\r\n* OK [UNSEEN 1] First unseen.\r\n* OK
[U"..., 318) = 318
26216 read(0, "3 UID fetch 1:* (FLAGS)\r\n", 4082) = 25
26216 write(1, "* 1 FETCH (UID 2538645720 FLAGS (\\Recent))\r\n3 OK Fetch
completed.\r\n", 67) = 67
26216 read(0, "4 UID fetch 2147483647 (UID RFC822.SIZE FLAGS
BODY.PEEK[HEADER.FIELDS (From To Cc Subject Date Message-ID Priority X-Priority
References Newsgroups In-Reply-To)])\r\n", 4057) = 164
26216 write(1, "4 OK Fetch completed.\r\n", 23) = 23
26216 read(0, "5 IDLE\r\n", 3893)       = 8
26216 write(1, "+ idling\r\n", 10)      = 10
26216 read(0, "DONE\r\n", 3885)         = 6
26216 write(1, "5 OK Idle completed.\r\n", 22) = 22
26216 read(0, "6 noop\r\n", 3879)       = 8
26216 write(1, "6 OK NOOP completed.\r\n", 22) = 22
26216 read(0, "7 UID fetch -2147483648:* (FLAGS)\r\n", 3871) = 35
26216 write(1, "7 BAD Invalid messageset: -2147483648:*\r\n", 41) = 41

Actual Results:  
Thunderbird display an error message about the invalid messageset.
The mailbox isn't able to be displayed, and the application occasionally
hangs.

Expected Results:  
obviously, thunderbird should correctly handle 32-bit id and fetch
the message.

Comment 1

14 years ago
possible dupes : bug 277905, bug 223942

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 277905 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.