Selecting an alternate stylesheet, then reload page causes default stylesheet to be used

VERIFIED DUPLICATE of bug 159387

Status

()

Firefox
Disability Access
--
major
VERIFIED DUPLICATE of bug 159387
14 years ago
14 years ago

People

(Reporter: Doug Hockin, Assigned: Aaron Leventhal)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I'm working on making a website accessible.  When an alternate stylesheet
is selected (e.g. by someone with different visual requirements), and then
the page is reloaded, the default stylesheet is used instead of the alternate
one previously selected.

If you select an alternate stylesheet, and then click a link to another
page on the same site, you end up with the default stylesheet again.

This makes stylesheets pretty much unusable for accessibility purposes.



Reproducible: Always
(Reporter)

Updated

14 years ago
Version: unspecified → 1.0 Branch

Comment 1

14 years ago
Can you link me to a page that has multiple stylesheets, or something, or create
a testcase for this?
(Reporter)

Comment 2

14 years ago
I've added the URL of the prototype of the website I'm working on.  It's
going to be part of a much bigger website.  There are two pages on my
site, the main page and the "Archive" page.  You can see everything I
described using those two pages and their stylesheets.

*** This bug has been marked as a duplicate of 159387 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

14 years ago
I just looked at the bug 159387 that you marked this as a duplicate of and it's
been languishing for over _2_ years with no action, not even any discussion of
how to fix it.  Any plans to fix it?

Looks like bug 159387 is marked as a duplicate of bug 83663?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.