From: not populated when 1st account selected

VERIFIED FIXED in M14

Status

MailNews Core
Composition
P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: esther, Assigned: rods (gone))

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] fix 3/1)

(Reporter)

Description

19 years ago
Using builds 2000-02-15-10 on win98 and linux and 2000-02-15-09 on Mac the From: 
addressing field is not expanded horizonally and populated when user has 
selected the 1st account of a profile that contains 2 or more accounts.

1. Launch Messenger  (with a profile that has 2 mail accounts)
2. Select the Inbox of the 1st account (give password if needed) and click the 
New Msg button.  
Notice the From field is just a drop-down button.
3. Close New Msg window 
4. Select the 2nd mail account (give password if necessary),  click on the New 
Msg button.
Notice the From field has the selected account as the From: 
Note: The outgoing server in this case was the same as the 1st account server.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → esther

Comment 1

19 years ago
*** Bug 27649 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
As reported in the bug I just duplicated:

1. The From line is not set, regardless of what account is selected, if you
Reply, Reply All, or Forward.

2. The message is not sent, and no error message is displayed.  That makes this
bug pretty bad, since it means messages are getting lost.  Marking dogfood.
Keywords: dogfood, regression
Summary: From: not populated when 1st account selected → From: not populated when 1st account selected and on Reply

Comment 3

19 years ago
Sorry, I take that back.  Message did get sent. It just took a long time for the
messages to arrive.
Keywords: dogfood

Comment 4

19 years ago
Nominate for beta1
Keywords: beta1

Comment 5

19 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]

Comment 6

19 years ago
Putting on PDT+ radar for beta1.

Comment 7

19 years ago
since this is PDT+, I'll set the target milestone from blank to M14.
Target Milestone: M14
cc'ing rods as it's a problem with dropdown list
Status: NEW → ASSIGNED
I've just checked that I was correctly setting the From select element with the 
correct items, there are ok. If I add an extrat dummy item (option) at the 
beginning of the select element, then everything is works fine. Looks like it's 
a problem when you set the select.value to the first item. Reassign to rods
Assignee: ducarroz → rods
Status: ASSIGNED → NEW
(Assignee)

Comment 10

19 years ago
The only problem I am seeing (other than the crash when I tried to get my home 
e-mail from my pop account) is the combobox doesn't show the correct value for 
my work imail account in the "From" field (the first account), in fact it is 
only a few pixels wider tthan the dropdown btn. 

When I switch to the second account and hit new message the "From" field lokks 
perfect.

I'll take a look at why the combobox is displaying any value even though 
there are at least two in the list.
Status: NEW → ASSIGNED
(Assignee)

Comment 11

19 years ago
For some reason the comboxbox isn't getting reflowed because block reflow 
doesn't think it is dirty and needs to be reflowed. Should be easy to fix, but I 
need to consult with buster.
(Assignee)

Comment 12

19 years ago
Ok, so it wasn't easy. I have had to rework Combobox reflow, which it really 
needed, and I am still testing. I get a warning out of reflow that I need to get 
rid of.
Whiteboard: [PDT+] → [PDT+] Making good progress, one more issue to work out

Comment 13

19 years ago
*** Bug 28411 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Depends on: 28460

Comment 14

19 years ago
*** Bug 28755 has been marked as a duplicate of this bug. ***

Comment 15

19 years ago
*** Bug 28794 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 16

19 years ago
This bug, as originally stated, was specific about the From: not being 
expanded for a NEW MSG on the 1st account only, (Reply, Reply To: or Forward 
msg was not part of this bug, the short description had been changed to include 
Reply).  As "rods" pointed out in his comment dated 2-17-2000 he is only seeing 
the problem in the 1st account when doing a NEW MSG.  The behavior is different 
when user is doing a Reply, Reply To or Forward (the From doesn't expand no 
matter which account you have selected a message in and is what duplicate bug 
27649 states).  Two bugs have been combined to one.  "rods" if this should be 2 
different bugs, please let me know and I will separate them.  If not, QA Note 
this should be tested to include New Msg, Reply, Reply To and Forward.  
Summary: From: not populated when 1st account selected and on Reply → From: not populated when 1st account selected
(Assignee)

Comment 17

19 years ago
The new rewrite of combobox reflow provides a 3x improvement in CPU time usage 
for laying out pages with several controls.
Whiteboard: [PDT+] Making good progress, one more issue to work out → [PDT+] 90% there, currently have a printing issue to work

Comment 18

19 years ago
If you want a separate bug for the case of Reply and Forward, you can reopen bug
27649.

Comment 19

19 years ago
Need ETA on fix for this in Status Whiteboard please.
(Assignee)

Comment 20

19 years ago
Still testing the rewrite
Whiteboard: [PDT+] 90% there, currently have a printing issue to work → [PDT+] fix 2/28

Comment 21

19 years ago
This looks like it's working for me on Linux build 2000.02.025.08; maybe fixed
along with bug 28460?
(Assignee)

Comment 22

19 years ago
This got fixed by a box layout fix, but I have rewritten the reflow for the 
combobox for performance.

Comment 23

19 years ago
Should we close this bug then?
(Reporter)

Comment 24

19 years ago
Using build 2000-02-28-09 on Win98 and 2000-02-28-08 on Mac, New Msg, Reply, 
Reply All, Forward all populate the From field with the selected account.  
Tested with 2 accounts, each one selected as I ran through the various Compose 
windows.   Note: Linux testing done by zach, Rod please Resolve this as fixed 
and I will verify.
(Assignee)

Comment 25

19 years ago
No, I don't want to close it until I get the new code checked in.
(Assignee)

Comment 26

19 years ago
updated status
Whiteboard: [PDT+] fix 2/28 → [PDT+] fix 3/1
(Assignee)

Comment 27

19 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 28

19 years ago
*** Bug 30063 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 29

19 years ago
Using win32 commercial build 2000-03-06-14, mac mozilla build 2000-03-06-08 and 
linux mozilla build 2000-03-06-13 this is fixed. I tried New Msg, 
Reply, Reply to All and Forward with the 1st account and then again 
with the 2nd account, From field was correct. Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.