If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Table/CSS rendering error - gaps appear between borders

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Nick Kochakian, Unassigned)

Tracking

({qawanted, testcase})

Trunk
qawanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Gaps seem to appear between some table cells when their borders have been set
through CSS. This seems to occur quite frequently in tables that have their
spacing and padding set to zero. The left and right edges of some adjacent cells
(as seen in the example) sometimes shift one pixel to the left or right instead
of staying lined up next to each other.

This problem can be made worse if the font size is decreased (or sometimes
increased.) Every time the font size is changed, the gap rendering error becomes
more (or less) obvious. The width of the cells in the example are fixed using
the em unit.

Reproducible: Always

Steps to Reproduce:
1. Open the example HTML file that contains the table
2. Decrease the font size if the error is not seen initially until one or more
gaps form between the vertical edges of adjacent cells




Tested on Windows and BSD versions of Firefox
(Reporter)

Comment 1

13 years ago
Created attachment 171642 [details]
Example HTML document that contains the incorrectly rendered table
(Reporter)

Comment 2

13 years ago
Created attachment 171643 [details]
Screen shot of what the table might look like when the page is initially loaded
(Reporter)

Comment 3

13 years ago
Created attachment 171644 [details]
Enlarged area of the table that contains a gap
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Component: Layout → Layout: Tables
Keywords: qawanted

Comment 4

13 years ago
Created attachment 179085 [details]
Another example. Border before the last x is visible if you have minimum font size <= 14 (no need to resize font)

Comment 5

13 years ago
Created attachment 179091 [details]
More clear example.

You don't need to assign borders at all to make this happen. All it needs is a
width for the td and the browser window needs to be large enough so that the
table width doesn't shrink due to it. 

It happens for example when td width is 22pt or 25pt, but it doesn't happen if
width is 23pt or 24pt or 26pt. So every 3rd number seems to make it happen.
View the source code of the example page and you should see how simple code it
needs.

Comment 6

13 years ago
wfm with winxp 2005040805, could you please retestw with a recent nightly?
Keywords: testcase

Comment 7

13 years ago
I tested and seems to be fixed in nightly 20050408.

Comment 8

12 years ago
marking as wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.