Last Comment Bug 278860 - confusing "profile in use"/"already running" error when profile is missing (not found)
: confusing "profile in use"/"already running" error when profile is missing (n...
Status: VERIFIED FIXED
[pm-ui]
: ux-error-recovery
Product: Toolkit
Classification: Components
Component: Startup and Profile System (show other bugs)
: unspecified
: All All
: P3 major with 34 votes (vote)
: mozilla14
Assigned To: Mike Kaply [:mkaply] (Out June 27-July 5)
:
Mentors:
: 294963 297142 305923 307951 311749 312728 312817 320241 324764 325559 325693 325950 332505 334953 345945 345946 348767 350327 356642 362130 362537 362817 364199 366693 367113 395720 408614 425070 430782 437034 442798 449369 459636 459991 460948 463174 469506 474267 476096 476956 515040 533615 549198 569001 584829 598228 619264 622784 622792 639307 644447 652340 669287 698973 753446 (view as bug list)
Depends on: 766494
Blocks: 381139 459638 tomtom
  Show dependency treegraph
 
Reported: 2005-01-18 10:04 PST by Josh Kelley
Modified: 2014-08-11 17:45 PDT (History)
103 users (show)
benjamin: blocking1.8.1.2-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
Change the wording of the dialog (1.03 KB, patch)
2007-09-17 23:46 PDT, Thomas Bertels
no flags Details | Diff | Review
Patch v1.0: Check if profile path is accessible before trying to lock (3.03 KB, patch)
2007-11-08 11:16 PST, Henrik Skupin (:whimboo)
no flags Details | Diff | Review
Patch v1.1: Same as v1.0 without mentioning missing profile data (2.99 KB, patch)
2007-11-08 13:04 PST, Henrik Skupin (:whimboo)
benjamin: review-
Details | Diff | Review
WIP v1 (9.31 KB, patch)
2009-12-04 06:25 PST, Gabriele Best [:Gabri]
no flags Details | Diff | Review
WIP v2 (9.14 KB, patch)
2009-12-05 13:47 PST, Gabriele Best [:Gabri]
benjamin: review-
Details | Diff | Review
Add directory check in three places (1.81 KB, patch)
2012-03-22 08:33 PDT, Mike Kaply [:mkaply] (Out June 27-July 5)
benjamin: review+
mark.finkle: approval‑mozilla‑central+
Details | Diff | Review
Fix for gPromptService problem (581 bytes, patch)
2012-05-01 07:02 PDT, Mike Kaply [:mkaply] (Out June 27-July 5)
dtownsend: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Review

Description Josh Kelley 2005-01-18 10:04:24 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If Thunderbird is configured to store its profile on a network drive, and if the
network drive is not connected when Thunderbird starts, it brings up the Profile
Manager and says that it cannot load the profile because it is in use.

Reproducible: Always

Steps to Reproduce:
1. Configure Thunderbird with a profile on a network drive.
2. Exit Thunderbird and disconnect the network drive.
3. Restart Thunderbird and attempt to load the profile that's on the network drive.

Actual Results:  
Thunderbird reports that the profile is in use.

Expected Results:  
Thunderbird reports that the profile directory cannot be found.  Ideally, it
might report that the drive cannot be found and give the directory that it's
looking for to help the user in diagnosing the problem.

I've seen this problem in Firefox 1.0 and Thunderbird 1.0.  It does not occur in
Mozilla 1.8a5; maybe it's been fixed there?  I apologize if it's already fixed
in the development version.
Comment 1 Benjamin Smedberg [:bsmedberg] 2005-02-04 13:51:15 PST
Good bug report, this is one of the many startup UI bugs that I intend to fix,
with lots of luck before 1.1.
Comment 2 Michael Lefevre 2005-05-21 11:55:27 PDT
*** Bug 294963 has been marked as a duplicate of this bug. ***
Comment 3 Michael Lefevre 2005-05-21 11:57:33 PDT
The error message is wrong. Doing something clever when the profile can't be
found might be an enhancement, but in the first instance it's a bug.
Comment 4 Gabriel Sjoberg 2005-09-12 15:02:44 PDT
*** Bug 307951 has been marked as a duplicate of this bug. ***
Comment 5 Adam Guthrie 2005-09-27 17:40:33 PDT
*** Bug 297142 has been marked as a duplicate of this bug. ***
Comment 6 Benjamin Smedberg [:bsmedberg] 2005-10-17 09:43:03 PDT
*** Bug 312728 has been marked as a duplicate of this bug. ***
Comment 7 Adam Guthrie 2005-10-18 18:24:47 PDT
*** Bug 312817 has been marked as a duplicate of this bug. ***
Comment 8 Benjamin Smedberg [:bsmedberg] 2005-11-10 06:39:12 PST
*** Bug 311749 has been marked as a duplicate of this bug. ***
Comment 9 Adam Guthrie 2005-11-29 08:20:14 PST
*** Bug 305923 has been marked as a duplicate of this bug. ***
Comment 10 guanxi 2005-12-03 15:00:41 PST
Many bugs duped to this one see behavior similar to the following.  You can also find several posts in Mozillazine's forums if you search for the error message below.

Firefox 1.5:

1)  Firefox not running

2)  Rename profile folder

3)  Start Firefox

4)  Displays window:

"Firefox is already running, but not responding. To open a new window, you must
first close the existing firefox process, or restart your system"
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-12-14 08:37:09 PST
*** Bug 320241 has been marked as a duplicate of this bug. ***
Comment 12 gekacheka 2005-12-16 23:03:25 PST
Occurs in all aviary apps (Firefox, Thunderbird, Sunbird)
There are two misleading error dialogs.

1. Create a new profile, say called test2:
   firefox.exe -p
   Create Profile
   test2

2. Exit firefox.

3. Delete test2 profile directory manually (name ends with .test2).

4. Start firefox.exe
Get dialog with misdiagnosis:

+---------------------------------------------------------------------+
 Close Firefox                                                      
   Firefox is already running, but is not responding.  To open a new
   window, you must first close the existing Firebird process, or    
   restart your system.                                              
+---------------------------------------------------------------------+

5. Start firefox.exe -p test2
Same "Close Firefox" message as #4.

6. Start firefox.exe -p
   Profile manager appears: select profile test2.

Get dialog with misdiagnosis:

+--------------------------------------------------------------------+
 Profile in Use                                                     
   Firefox Cannot use the profile "test2" because it is in use.
   To continue, close the running instance of Firefox or choose a
   different profile                                          
+--------------------------------------------------------------------+

WORKAROUND: (if profile is to be deleted, not just disconnected.)
9. Start firefox.exe -p
   Profile manager appears: delete profile test2.
   Create a new profile, or select a previously existing profile.

(Initial search for comments with these error messages did not turn up
this bug because 'is' was missing from comment 10.)

Messages are in 
http://lxr.mozilla.org/mozilla/source/toolkit/locales/en-US/chrome/mozapps/profile/profileSelection.properties

First dialog appears to be displayed by ProfileLockedDialog.
http://lxr.mozilla.org/mozilla/source/toolkit/xre/nsAppRunner.cpp#1226

ProfileLockedDialog called when lock fails for any reason (CPP).
http://lxr.mozilla.org/mozilla/source/toolkit/xre/nsAppRunner.cpp#1473
http://lxr.mozilla.org/mozilla/source/toolkit/xre/nsAppRunner.cpp#1553
http://lxr.mozilla.org/mozilla/source/toolkit/xre/nsAppRunner.cpp#1603

Second dialog also appears when lock fails for any reason (JavaScript).
http://lxr.mozilla.org/mozilla/source/toolkit/profile/content/profileSelection.js#122

Simple solution would be to broaden the messages to account for other reasons the lock operation can fail.  More involved solution would check if directory exists and give an alternate message if not.

Simple combined messages might be something like

+--------------------------------------------------------------------+
 Profile Unavailable

  The profile may either be locked or unreachable.  If it is locked by
  an existing Firefox process, you must first close Firefox or restart
  your system.
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
 Profile "test2" Unavailable

  The profile "test2" may either be locked or unreachable.  If it is
  in use, close the running instance of Firefox or choose a different
  profile.
+--------------------------------------------------------------------+

Hope this helps.
Comment 13 Sonya 2006-01-04 21:01:46 PST
I don't really understand about finding the identities and all of that, but my saved bookmarks and tabs appear to be gone and I don't know how to change the "user" - it said that my name was in use (it wasn't) and that I had to make up a new name, so I did - and now I have nothing. Please help.
I am using Windows XP and Firefox.

Thank you!
Comment 14 zug_treno 2006-01-27 03:45:52 PST
*** Bug 324764 has been marked as a duplicate of this bug. ***
Comment 15 Adam Guthrie 2006-02-02 17:55:40 PST
*** Bug 325559 has been marked as a duplicate of this bug. ***
Comment 16 Dave Townsend [:mossop] 2006-02-03 16:27:37 PST
*** Bug 325693 has been marked as a duplicate of this bug. ***
Comment 17 Benjamin Smedberg [:bsmedberg] 2006-02-05 04:53:26 PST
*** Bug 325950 has been marked as a duplicate of this bug. ***
Comment 18 floschroeck 2006-02-26 03:57:21 PST
same problem here. i use multiple profiles and they are not always available. iirc  old versions of firefox displayed the profile manager if the profile was not found - it would be very nice, if this would be like this again. perhaps the profile manager could have some field with the error message, that the profile wasn't found?

(FF 1.5.0.1, WinXP SP2)
Comment 19 Dave Townsend [:mossop] 2006-04-02 10:46:59 PDT
*** Bug 332505 has been marked as a duplicate of this bug. ***
Comment 20 Fox2 2006-04-02 11:55:13 PDT
Comments transferred from duplicate 332505:

If the profile folder cannot be found on program startup, the user gets the "firefox is already running" message. Since profiles.ini persists through reboot and reinstall, and profile folder is only ever created by the installer in the default location and not in the location pointed to by profiles.ini, the problem persists during reboot and reinstall.

Steps to reproduce: Quit firefox. Rename profile folder (as linked from profiles.ini) to some other name (eg "profile.temp") and try to run firefox. Program will not start up. Error message "Firefox is already running". Rename the profile folder back to same name as in profiles.ini, and it works again.

Analysis: When firefox reinstalled, the installer did NOT recreate profiles.ini. Instead, it seems it had noted there was an existing profiles.ini and left it as it was. Since I'd deleted the old profile in anticipation of reinstall, hence on program startup it couldn't find the profiles folder and failed to start as above. The flaw is primarily in the installer, it EITHER does not rewrite  rofiles.ini to point to the profiles folder, OR does not check the profile folder actually exists and is valid. But it should also be caught on program startup too, in cae of a disconnected or deleted profile folder.

Further observation #2: What would happen if the folder pointed to existed from an old install, or existed but contained certain corrupt data? Would the user be stuck with a mysteriously failing firefox that no matter how often they reinstalled failed to run correctly? Should the installer ask for a profile folder location, or check if it already exists whether to create a new (empty) one?
Comment 21 Fox2 2006-04-02 12:01:00 PDT
I think the allocation should be changed to major: any issue that means a program can be blocked from launching and persists past reinstall and reboot, and whose explanation and solution (via profile manager) is on an obscure page of the mozilla wiki that you have to know exists to find out about, is not a "normal" level of issue.

At the very least the error message needs updating to explain that profile issues can cause this error, see LINK, so users who get it can solve it, and also the profile manager shortcut should be added to the Fx start menu since its a function many people will find useful.
Comment 22 Mark Purtill 2006-04-20 16:58:47 PDT
This is not limited to Windows XP.  I just had the following situation: my Linux box crashed (yes, it does happen, especially when one presses the reset button).  Two lock files were left in the profile (lock and .parentlock, I think); on rebooting, I got the incorrect message "Firefox is already running, but not responding." The message which went on to suggest that I close firefox (which wasn't running; yes, I checked with ps) or restart my computer (which I had just done and in any case would have had no effect on the two lock files).

A link to solutions to the problem would have been nice, but as a general rule might not be so useful if firefox is the only browser on the machine.
Comment 23 Ria Klaassen (not reading all bugmail) 2006-04-21 07:26:52 PDT
*** Bug 334953 has been marked as a duplicate of this bug. ***
Comment 24 Ralf Hauser 2006-05-04 06:36:36 PDT
Sure, if I had meticulously followed http://www.mozilla.org/support/firefox/profile#move , this wouldn't have happened to me.

But being able to take your profile with you when you move from an old to a new computer ought to be more fool-proof!
Comment 25 Matthew Kidd 2006-06-11 02:10:47 PDT
While the Thunderbird message is somewhat meaningful, the equivalent Firefox message is completely misleading:

   "Firefox is already running but is not responding. To open a new window,
    you must first close the existing Firefox process, or restart your system."

I totally agree with comment #21 (from Fox2). The priority should be changed to major, at least until the error message is fixed at which point it can changed back to normal. 

In addition to the "deleted profile", "renamed profile", and "profile on unavailable network drive" scenarios already mentioned, one can run into the same problem by using a profile on a USB memory device, exiting Firefox, removing the USB device, and trying to restart Firefox. Hence, one more reason to fix the problem.
Comment 26 Adam Guthrie 2006-07-26 21:28:46 PDT
*** Bug 345946 has been marked as a duplicate of this bug. ***
Comment 27 Adam Guthrie 2006-07-26 21:29:18 PDT
*** Bug 345945 has been marked as a duplicate of this bug. ***
Comment 28 Adam Guthrie 2006-08-15 13:56:08 PDT
*** Bug 348767 has been marked as a duplicate of this bug. ***
Comment 29 Ria Klaassen (not reading all bugmail) 2006-08-26 13:24:05 PDT
*** Bug 350327 has been marked as a duplicate of this bug. ***
Comment 30 James 2006-08-27 21:33:35 PDT
This was also a regular issue for student users in our Mac OS X computer labs -  we started to get complaints in February 2006.  They all have network home directories mounted from a remote file server and Firefox frequently failed to clean up its lock files on exit, or logout.  As a workaround we provided a login hook which searches their profile and deletes any lock files.  Fewer students use Thunderbird, but they get the "profile is in use" message and call for help.

Firefox and Thunderbird have both had their wings clipped by this one.  The bug is still there and so is our crude workaround.  Here is our login hook which runs as the user logging in:

#! /bin/sh

# Remove all Firefox lock files created from the current IP address

# Discover the IP address of the ethernet interface on this machine
ipAddress=`/sbin/ifconfig en0 | /usr/bin/sed -ne '/inet /p' | /usr/bin/cut -d" " -f2`

# First argument passed to login hook is the path to the user's home directory
userHomeDir=$1

/usr/bin/find $userHomeDir/Library/Application\ Support/Firefox/Profiles -name "${ipAddress}:[0-9]*" -exec /bin/rm {} \;
/usr/bin/find $userHomeDir/Library/Application\ Support/Firefox/Profiles -name ".parentlock" -exec /bin/rm {} \;

exit
Comment 31 IU 2006-09-23 13:42:29 PDT
Is this bug going to be addressed?  Way back on February 4, 2005, Benjamin Smedberg wrote: "Good bug report, this is one of the many startup UI bugs that I intend to fix, with lots of luck before 1.1."

It's now September 23, 2006, Thunderbird 2 has entered Alpha, Firefox 2 is pushing RC1, and the bug is just as fresh as February 4, 2005.  Not that I know how to fix it. :-)
Comment 32 Magnus Melin 2006-10-14 07:03:40 PDT
*** Bug 356642 has been marked as a duplicate of this bug. ***
Comment 33 Magnus Melin 2006-11-29 09:31:13 PST
Most of the dupes talk about "already running" -updating summary. Seems that what it says nowadays...
Comment 34 Magnus Melin 2006-11-29 10:04:37 PST
*** Bug 362130 has been marked as a duplicate of this bug. ***
Comment 35 Ria Klaassen (not reading all bugmail) 2006-12-01 14:07:27 PST
*** Bug 362537 has been marked as a duplicate of this bug. ***
Comment 36 Ria Klaassen (not reading all bugmail) 2006-12-05 03:43:21 PST
*** Bug 362817 has been marked as a duplicate of this bug. ***
Comment 37 Magnus Melin 2006-12-18 08:23:02 PST
*** Bug 364199 has been marked as a duplicate of this bug. ***
Comment 38 Henrik Skupin (:whimboo) 2006-12-18 14:10:23 PST
Seems that this bug was forgotten. Benjamin, any change to get this in?
Comment 39 Benjamin Smedberg [:bsmedberg] 2006-12-18 17:39:35 PST
If somebody provides a patch, I'd be happy to review it. This does not block any releases.
Comment 40 BASSET 2006-12-30 03:37:26 PST
Hi,

It's maybe a good idea to  add a warning in http://kb.mozillazine.org/Moving_your_profile_folder, until the bug is removed. 

Something like "Warning: due to bug 278860, thunderbird will repport the wrong error "Firefox is already running, but is not responding.[...]" wenn misspelling your directory. Whenn this error occurs, first check the .ini file you modified"

(ps: I tried to submit this in the online help using [edit], but my account did not work.)
Comment 41 Alice Wyman 2006-12-30 06:21:39 PST
(In reply to comment #40)
> Hi,
> 
> It's maybe a good idea to  add a warning in
> http://kb.mozillazine.org/Moving_your_profile_folder, until the bug is removed. 
> 
Done.

The Firefox or Thunderbird "already running but is not responding" error can also occur if the wrong profile path is entered after the "-profile" command line argument. This can result in the "already running" error when a user incorrectly tries to start the Profile Manager from the command line using "-profile manager" instead of "-profilemanager".  I also added a note about that to http://kb.mozillazine.org/Profile_Manager#Accessing_the_Profile_Manager 

Comment 42 Phil Ringnalda (:philor) 2007-01-11 09:17:01 PST
*** Bug 366693 has been marked as a duplicate of this bug. ***
Comment 43 Ria Klaassen (not reading all bugmail) 2007-01-16 07:11:51 PST
*** Bug 367113 has been marked as a duplicate of this bug. ***
Comment 44 Majken Connor [:Kensie] 2007-04-25 16:47:33 PDT
ccing mconnor - I remember him saying something about wanting "polish" bugs for 3 and I believe this one would count.

What all needs to be done? Does the code detect that the profile is missing but is falling back on a poor error dialog?
Comment 45 Benjamin Smedberg [:bsmedberg] 2007-04-26 06:39:47 PDT
Right now it basically detects that it couldn't lock the profile. This happens to be because the profile folder doesn't exist, rather than because the profile is already locked. It wouldn't be hard to add an explicit check for existence and propagate that error code back.
Comment 46 Henrik Skupin (:whimboo) 2007-04-26 07:01:48 PDT
(In reply to comment #45)
> to be because the profile folder doesn't exist, rather than because the profile
> is already locked. It wouldn't be hard to add an explicit check for existence

Further it also happens for profiles which are located on network shares. If you wake up your computer and no other software has used the mapped drive before you start Firefox or Thunderbird it will also fail.

Comment 47 BASSET 2007-04-27 04:41:45 PDT
What do you think about changing the message error to have something more explicit like "Thunderbird could not open the profile file xxx in read/write mode, please check filename, filelocation and write possibility"
Comment 48 Benjamin Smedberg [:bsmedberg] 2007-09-10 16:08:06 PDT
*** Bug 395720 has been marked as a duplicate of this bug. ***
Comment 49 Paul Smith 2007-09-17 19:46:00 PDT
(In reply to comment #46)
> (In reply to comment #45)

>Absolutely right Henrik, 

All of our Thunderbird email profiles are mapped to m:\ on a file server for centralised email backup.

If the network drive M:\ is not initialised by another program first on the local computer,then TB reports "Profile in use". This was totally misleading. 

What it should say is "Network drive unavailable, cannot load profile". But even that isn't quite true, because it was available. TB just hadn't initialsed the network M:\ before looking for the profile.

My work around is to have another program look at M:\ first. After this TB can see m:\, and it's profile. I use windows explorer in start up to do this.

The program fix should have TB look at the network drives, initialise them, then look for the profile. This would really help with wireless network drives which we use and occasionally go down.

Comment 50 Thomas Bertels 2007-09-17 23:46:05 PDT
Created attachment 281283 [details] [diff] [review]
Change the wording of the dialog

While (and/or because) the backend can't make the difference for now, let's just change the wording.
I suggest 
>Profile In Use Or Inaccessible
for the title and
>%S cannot use the profile "%S" because it is in use or inaccessible.\n\nTo >continue, close the running instance of %S, choose a different profile or make >this one accessible.
for the content.
Comment 51 Benjamin Smedberg [:bsmedberg] 2007-09-18 02:57:07 PDT
Why doesn't somebody just write a patch to propagate and test for the error? This isn't rocket science, it just needs a coder.
Comment 52 Henrik Skupin (:whimboo) 2007-10-31 06:27:29 PDT
When we are trying to lock the profile, we don't differentiate between the different Exceptions which could be thrown by nsProfileLock:

http://mxr.mozilla.org/seamonkey/source/toolkit/profile/content/profileSelection.js#120
http://mxr.mozilla.org/seamonkey/source/profile/dirserviceprovider/src/nsProfileLock.cpp#143

Someone should add code to differentiate between the thrown Exceptions.

Axel, are these late l10n changes already possible or is it too late for Firefox 3?
Comment 53 Axel Hecht [:Pike] 2007-10-31 06:36:44 PDT
Right now, I don't think that l10n impact governs that decision. Whether we'd take this patch for M10 or not is likely going to be based on a risk analysis, I doubt it has an severe l10n impact.
Comment 54 Henrik Skupin (:whimboo) 2007-11-08 11:16:48 PST
Created attachment 287869 [details] [diff] [review]
Patch v1.0: Check if profile path is accessible before trying to lock

This patch contains string changes and will impact l10n.

Before we try to lock the profile we should check if the given path is accessible and is a directory. That will stop all other exceptions. I combined both checks into one alert message.
Comment 55 Jonathan Haas 2007-11-08 12:23:52 PST
> +profileNotAccessible=%S cannot use the profile "%S" because its given path is not accessible or contains no profile data files.

AFAIK you can also use an empty directory without causing any problems. So "or contains no profile data files" seems to be not needed. You are not checking for empty directories, too.
Comment 56 Henrik Skupin (:whimboo) 2007-11-08 13:04:07 PST
Created attachment 287885 [details] [diff] [review]
Patch v1.1: Same as v1.0 without mentioning missing profile data

> AFAIK you can also use an empty directory without causing any problems. So "or
> contains no profile data files" seems to be not needed. You are not checking
> for empty directories, too.

You are right. An empty directory works fine. I've removed the second part of the sentence.

But anyway I would like to wait what Benjamin says in general before updating the patch once more.
Comment 57 Majken Connor [:Kensie] 2007-11-08 13:23:24 PST
Is there a different message for when the directory doesn't exist? That doesn't work, I thought the second bit of the string was in reference to that.
Comment 58 Henrik Skupin (:whimboo) 2007-11-08 14:41:00 PST
No, it's the same message. If the given path doesn't exist or isn't a directory the alert will be shown. I have to test for existence first because I get an exception otherwise when only calling isDirectory. 
Comment 59 Benjamin Smedberg [:bsmedberg] 2007-11-09 10:44:38 PST
Comment on attachment 287885 [details] [diff] [review]
Patch v1.1: Same as v1.0 without mentioning missing profile data

This is not the correct place for this code (or at least it's not sufficient). If you launch with -P test we need the error-checking to occur here: http://mxr.mozilla.org/mozilla/source/profile/dirserviceprovider/src/nsProfileLock.cpp#262 and here: http://mxr.mozilla.org/mozilla/source/toolkit/xre/nsAppRunner.cpp#1908
Comment 60 Henrik Skupin (:whimboo) 2007-11-11 13:40:45 PST
Benjamin, just a question before I have a look into the cpp files... Do the Profile Manager and command line switch share some backend code, so all the js stuff I made can be moved there? Or do we definitely need my patch for the PM?

Runing Firefox with the switch -p and a profile which points to an invalid directory shows me an empty dialog on OS X. Also if it's already locked I get a different message as on Win/Lin. I searched mxr and found following code:

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/toolkit/xre/nsAppRunner.cpp&rev=1.198&mark=1645-1651#1645

Does checking for an invalid directory and its output also needs different implementation?
Comment 61 Benjamin Smedberg [:bsmedberg] 2007-11-26 13:53:20 PST
Normal usage is hidden behind the profile-locking code which is called from nsIToolkitProfileService.lockProfilePath or nsIToolkitProfile.lock
Comment 62 Phil Ringnalda (:philor) 2007-12-16 15:01:13 PST
*** Bug 408614 has been marked as a duplicate of this bug. ***
Comment 63 Henrik Skupin (:whimboo) 2008-01-19 06:47:41 PST
Sorry, but for now its a bit too hard for me to build a patch. 
Comment 64 Phil Ringnalda (:philor) 2008-03-26 09:38:17 PDT
*** Bug 425070 has been marked as a duplicate of this bug. ***
Comment 65 David Flory 2008-04-03 10:45:01 PDT
This bug appears to be over three years old.  The error message given by both FF and TB is both misleading and incorrect.  
Comment 66 Rod Whiteley 2008-04-07 08:25:26 PDT
*** Bug 427533 has been marked as a duplicate of this bug. ***
Comment 67 Karsten Düsterloh 2008-04-25 03:45:19 PDT
*** Bug 430782 has been marked as a duplicate of this bug. ***
Comment 68 Alan Agnew 2008-05-03 05:48:28 PDT
Surely the accessibility of the profile path does not need to be checked every time an attempt is made to lock the profile, just once at the beginning of the application before any attempts are made to lock the profile.
  
Comment 69 Joe Sabash [:JoeS1] 2008-08-06 20:26:10 PDT
*** Bug 449369 has been marked as a duplicate of this bug. ***
Comment 70 Thomas Bertels 2008-08-07 07:34:05 PDT
*** Bug 437034 has been marked as a duplicate of this bug. ***
Comment 71 Phil Ringnalda (:philor) 2008-10-13 15:25:59 PDT
*** Bug 459636 has been marked as a duplicate of this bug. ***
Comment 72 Henrik Skupin (:whimboo) 2008-10-16 12:34:47 PDT
*** Bug 459991 has been marked as a duplicate of this bug. ***
Comment 73 Magnus Melin 2008-10-21 06:43:43 PDT
*** Bug 460948 has been marked as a duplicate of this bug. ***
Comment 74 Ria Klaassen (not reading all bugmail) 2008-11-05 11:34:38 PST
*** Bug 463174 has been marked as a duplicate of this bug. ***
Comment 75 Ray Kiddy 2008-11-08 10:12:26 PST
Might it be possible to separate some of the concerns in this bug? Looking at the history of it, it seems even that even small bits of progress are stymied, probably because of the mesh of all the other issues.

Can some one with word-smith-ability propose an acceptable message for the alert?

Someone else could implement the change to make a new alert message come up, no?

Should there be different exceptions getting thrown here? It seems as though "I have a directory or file and cannot lock it" would throw a different exception than "I cannot find the directory or file". Perhaps if the lock fails to happen, code can check which factor is causing the problem and throw a more informative exception.
Comment 76 Phil Ringnalda (:philor) 2008-12-13 17:32:31 PST
*** Bug 469506 has been marked as a duplicate of this bug. ***
Comment 77 Ria Klaassen (not reading all bugmail) 2009-01-19 00:32:12 PST
*** Bug 474267 has been marked as a duplicate of this bug. ***
Comment 78 Lucian 2009-01-19 06:56:12 PST
As a matter of fact, this error does not say true. It should be changed to "Error: Profile folder was not found. Please use profile manager to find correct path. [Profile Manager] [Create new default profile] [Cancel]"
Comment 79 Phil Ringnalda (:philor) 2009-01-29 20:25:54 PST
*** Bug 476096 has been marked as a duplicate of this bug. ***
Comment 80 Matthias Versen [:Matti] 2009-02-04 16:56:37 PST
*** Bug 476956 has been marked as a duplicate of this bug. ***
Comment 81 Geoffrey G Wright 2009-07-29 23:02:57 PDT
This bug appears to be nearly five years old. The error message is both misleading and incorrect.
Comment 82 Ria Klaassen (not reading all bugmail) 2009-09-07 09:58:37 PDT
*** Bug 515040 has been marked as a duplicate of this bug. ***
Comment 83 Gabriele Best [:Gabri] 2009-12-04 06:25:32 PST
Created attachment 416081 [details] [diff] [review]
WIP v1

I'd like to know what benjamin thinks about this approach (same of bug 531532)
Comment 84 Gabriele Best [:Gabri] 2009-12-04 06:30:28 PST
The patch works but if I click on "Ok" (I want to create the missing profile folder), firefox crashes between the first and the second printf. I don't know why.

Step to reproduce (comment 12):
1. Create a new profile, say called test2:
   firefox.exe -p
   Create Profile
   test2

2. Exit firefox.

3. Delete test2 profile directory manually.

4. Start firefox.exe

5. Click on "Ok"

Firefox crashes after creating the profile folder.
Comment 85 Gabriele Best [:Gabri] 2009-12-05 13:47:48 PST
Created attachment 416294 [details] [diff] [review]
WIP v2

This works but I don't think the dialog box is completly correct.
It should answer to the user where is the new profile folder (in case of -p argument)
Comment 86 spamprotector 2009-12-09 06:10:20 PST
It would be very great if there were improvements made in the profile selection system.
If the profile is not found the user should get a popup with these possibilities.

-Search for the profile path
-choose an alternative profile manually
-automatically choose another profile if 1st profile is not available

Mfg Urmel
Comment 87 WADA 2009-12-14 17:55:00 PST
*** Bug 533615 has been marked as a duplicate of this bug. ***
Comment 88 halfdog 2010-01-10 01:31:07 PST
Also affects recent seamonkey:
Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100108 SeaMonkey/2.1a1pre
Comment 89 halfdog 2010-01-10 02:08:51 PST
Has someone tested the patch from Gabriele Best [:Gabri] (2009-12-05)? Is it already included in a firefox, seamonkey version, but not seam2.1a1? If not, is someone already going through "Life Cycle of a Patch" (http://www-archive.mozilla.org/hacking/life-cycle.html)?
Comment 90 :Aryeh Gregor (away until August 15) 2010-01-10 04:13:39 PST
As you can see at the top of the page, the patch is marked "gabri.best: review? (benjamin)".  That means it's up to the stage "Ask a module owner or peer for the module in question explicitly for a review".
Comment 91 Benjamin Smedberg [:bsmedberg] 2010-01-12 09:24:20 PST
Comment on attachment 416294 [details] [diff] [review]
WIP v2

Users don't have enough context to answer this question. In any case, I'm trying to remove the profile manager in bug 214675, so I think this problem will be mostly moot.
Comment 92 Phil Ringnalda (:philor) 2010-02-28 12:34:33 PST
*** Bug 549198 has been marked as a duplicate of this bug. ***
Comment 93 Dick 2010-05-18 07:02:54 PDT
For what it's worth, I believe this bug still exists on the latest Thundebird (ver 3.0.4).  I installed TB on XP Pro client computers (SP3 with latest patches) at my wife's business with a Windows 2000 server and a network.  The profile folder was on a mapped drive (on the server) and we are intermittently getting the "Thunderbird is already running..." message on one of the clients.  Was the initialization of the mapped drives done on this version? It seems that sometimes we get the message and sometimes we don't.  (We also have NOD32 anti-virus running on its start-up scan so I don't know if that is a contributing cause.)  Out of 3 reboots, I got the error once; it's not consistent.
Comment 94 Jeff Hammel 2010-05-29 10:30:15 PDT
*** Bug 569001 has been marked as a duplicate of this bug. ***
Comment 95 Dave Aton 2010-07-12 13:32:02 PDT
Wow, a five-and-a-half-year-old bug that's still not fixed? (Yes, I've seen it intermittently for years, and I'm seeing it in ver 3.x.) Is it a hard one to fix, or just a low priority?
Comment 96 Matthias Versen [:Matti] 2010-08-05 22:22:08 PDT
*** Bug 584829 has been marked as a duplicate of this bug. ***
Comment 97 Tom Roche 2010-09-04 10:31:00 PDT
Bug exists in firefox=3.6.8 on ubuntu lucid. I setup my account (which unfortunately required a different username=bar) on a new box by restoring from a backup on my current one (on which my username=foo). I got the error, which confused me until I remembered to fix profiles.ini on the new box (sed -sie 's|/home/foo|/home/bar|g)
Comment 98 Geoffrey G Wright 2010-11-25 07:15:34 PST
Six years. Is there any interest in fixing this? The error message is both
misleading and incorrect. Is it a hard one to fix, or just a low priority?
Comment 99 Jens Foerster 2010-11-25 07:58:19 PST
Bug still exists with Firefox 3.6.12 and Thunderbird 3.1.6 (under Linux Mint 10 (Gnome 64-bit).
The buggy message occurs very easily if the profiles are stored on a mounted drive and I forgot to mount it after boot.
What _really_ is necessary is to change the message text. It should point the user into the right direction, in this case something with "profile not found"
Is it so hard to fix? If not, please rise its priority!
Comment 100 Frank-Ralph Reiser 2010-11-25 08:07:31 PST
Yes, I still am interested.

1) Without the ability to switch profiles, tracking down configuration issues or bugs in addons is rather difficult.
2) Without the ability to run two or three firefox instances with different profiles, comparing the behaviour of different firefox versions is nearly impossible.

Fixing the message text is one thing, but in my opinion it's only a minor step.
I think it is rather necessary to clean up the whole profile and version handling of firefox.
If firefox can find out that there's another instance already running, how about finding out which version and which profile it's running and presenting options accordingly?
Comment 101 Michał Gołębiowski [:m_gol] 2010-11-25 09:31:51 PST
(In reply to comment #100)
> 2) Without the ability to run two or three firefox instances with different
> profiles, comparing the behaviour of different firefox versions is nearly
> impossible.
But it's possible... Just not from GUI, that's what -no-remote switch is for.
Comment 102 Matthias Versen [:Matti] 2010-12-14 22:27:27 PST
*** Bug 619264 has been marked as a duplicate of this bug. ***
Comment 103 Wayne Mery (:wsmwk, NI for questions) 2011-01-12 21:09:26 PST
*** Bug 622792 has been marked as a duplicate of this bug. ***
Comment 104 Wayne Mery (:wsmwk, NI for questions) 2011-01-12 21:17:22 PST
*** Bug 442798 has been marked as a duplicate of this bug. ***
Comment 105 Wayne Mery (:wsmwk, NI for questions) 2011-01-13 06:14:43 PST
*** Bug 598228 has been marked as a duplicate of this bug. ***
Comment 106 Igor Levicki 2011-01-13 07:53:42 PST
Since my bug report got marked as a duplicate I am transferring what I consider usefull info here.

This isn't just a simple bug, it is an improper way to detect running instances of an application on the Windows platform -- code for detection should be made platform specific and proper code should be added.

On Windows platform, the usual way to detect another instance of a running application is to CreateMutex() (global, named) upon startup. If that fails
with GetLastError() == ERROR_ALREADY_EXISTS, then the application is already
running. Only then you should show "Application XYZ is already running" message.

Second part of the solution when the profile is really inaccessible for whatever reason is to let the user know that the profile is (temporarily) inaccessible, and perhaps offer an option to retry after user corrects the condition (i.e. by mounting the drive) or to create a new profile elsewhere.
Comment 107 Robert Strong [:rstrong] (use needinfo to contact me) 2011-01-13 08:02:28 PST
(In reply to comment #106)
> Since my bug report got marked as a duplicate I am transferring what I consider
> usefull info here.
> 
> This isn't just a simple bug, it is an improper way to detect running instances
> of an application on the Windows platform -- code for detection should be made
> platform specific and proper code should be added.
> 
> On Windows platform, the usual way to detect another instance of a running
> application is to CreateMutex() (global, named) upon startup. If that fails
> with GetLastError() == ERROR_ALREADY_EXISTS, then the application is already
> running. Only then you should show "Application XYZ is already running"
> message.
CreateMutex, etc is already used and support for having multiple profiles is the reason using CreateMutex isn't sufficient to fix this.
Comment 108 Igor Levicki 2011-01-13 08:25:29 PST
(In reply to comment #107)
> CreateMutex, etc is already used and support for having multiple profiles is
> the reason using CreateMutex isn't sufficient to fix this.

CreateMutex() should be sufficient to prevent both Firefox and Thunderbird from showing "Application is already running" when they cannot access the profile. 

What they should show when they really cannot access the profile is open for debate.
Comment 109 Robert Strong [:rstrong] (use needinfo to contact me) 2011-01-13 08:41:55 PST
I should have stated "use multiple profiles". When not using -no-remote and the app is already running the instance that is launched hands off urls to the running instance. When running multiple profiles using -no-remote it doesn't set up the mutex and there currently isn't a method to reliably detect this case. Since this is per user and a different user can technically use a different user's profile just using a mutex isn't sufficient though that is an edgecase.
Comment 110 Igor Levicki 2011-01-13 09:35:28 PST
If I launch Firefox using a desktop icon created by setup (i.e. with no special command line switches) and if its only profile specified by absolute path (see below) is not accessible (due to the volume not being mounted for example) it will tell me that it is already running which is quite obviously wrong.

-- snip from profiles.ini --
[Profile0]
Name=default
IsRelative=0
Path=M:\DATA\FF
-- snip from profiles.ini --

Note that I am not even touching multi-profile and multi-user issues here and I still have the same problem -- application which is unable to discern whether it is already running or not.
Comment 111 Daira Hopwood 2011-03-17 11:15:45 PDT
It has taken over 6 years to fix an error message that everyone agrees is incorrect (in both Firefox and Thunderbird), and that has been reported as a bug no less than 50 times. What's the holdup?

Incidentally, another possible cause is that the file permissions on the profile folder are wrong, or it is mounted read-only.
Comment 112 Matthias Versen [:Matti] 2011-03-24 07:36:48 PDT
*** Bug 644447 has been marked as a duplicate of this bug. ***
Comment 113 Vadim Rapp 2011-03-24 12:29:31 PDT
"firefox is already running" also shows up when the profile is in place, but the drive where it's located is full.
Comment 114 Matthias Versen [:Matti] 2011-07-05 14:30:43 PDT
*** Bug 669287 has been marked as a duplicate of this bug. ***
Comment 115 Dirk Schoettler 2011-08-24 11:11:49 PDT
Why is this ticket "New" after 6 years?

Suggestion:
Yes, it would be a great help to change the text of the error message to 
 "Your user profile data at <path> can't be read. 
 (This may happen when another instance of the program 
  is already running, or the path is wrong.)"

Last weekend when I helped someone fix his computer with the "already-running"-message, I spent half an hour with updating Thunderbird, rebooting the PC, checking the task manager. Just by instinct I finally examined the profiles.ini and discovered that the profile directory had been moved.
Comment 116 VanillaMozilla 2011-08-24 15:10:50 PDT
(In reply to Dirk Schoettler from comment #115)
> Suggestion:
> Yes, it would be a great help to change the text of the error message

Yes, time to get this changed, and do it the easy way.  Why not just change the string so it covers all cases?

I suggest
"Your user profile data cannot be read. 
This can happen when Thunderbird is already running or the profile cannot be found."

Simple and short.
Comment 117 Stefano Fraccaro 2011-08-24 21:18:30 PDT
Simple and short... I agree   :-)
Comment 118 Vadim Rapp 2011-08-25 07:15:03 PDT
I suggest

"<product> can't work with the configured user profile at <path> because of <reason>"

Note that "reason" can be "drive full", among other things. Since <product> probably does know the detailed reason from the specific system code, why not to tell it to the user. Telling <path> will also help to look into the right place, rather than begin research "where does firefox keep its profile".
Comment 119 Tom Roche 2011-08-25 08:20:37 PDT
@Vadim Rapp: +1
Comment 120 Dirk Schoettler 2011-08-28 13:01:10 PDT
Vadim, Tom, a detailed error message helps a lot to cure a problem, yes.

Though, if its too complicated for the programmer to distinguish between the causes (directory not found, file not found, file locked, file corrupt...) then I would definitively prefer a simple & early fix! 

IMHO a sophisticated solution here is not worth waiting some more years...
Comment 121 VanillaMozilla 2011-08-29 11:58:16 PDT
A detailed message has been tried, but 6 years later there is still no patch.

A static message would be perfectly adequate if it were correct.  Now, can somebody please just submit a patch?
Comment 122 John David Galt 2011-11-02 10:18:02 PDT
*** Bug 698973 has been marked as a duplicate of this bug. ***
Comment 123 Paul Silaghi, QA [:pauly] 2012-02-06 07:47:17 PST
*** Bug 622784 has been marked as a duplicate of this bug. ***
Comment 124 Paul Silaghi, QA [:pauly] 2012-02-07 01:51:10 PST
(In reply to guanxi from comment #10)
> Many bugs duped to this one see behavior similar to the following.  You can
> also find several posts in Mozillazine's forums if you search for the error
> message below.
> 
> Firefox 1.5:
> 
> 1)  Firefox not running
> 
> 2)  Rename profile folder
> 
> 3)  Start Firefox
> 
> 4)  Displays window:
> 
> "Firefox is already running, but not responding. To open a new window, you
> must
> first close the existing firefox process, or restart your system"

Still a major issue on latest Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120206 Firefox/13.0a1.
Even re-installing Firefox doesn't make it able to start after profile deletion.
Comment 125 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-03-22 06:47:50 PDT
Bug 237127 added in a profile missing dialog. I believe now it is just a matter of hooking up to this particular error case.
Comment 126 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-03-22 06:48:25 PDT
ARGH. Bug 237128
Comment 127 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-03-22 08:33:46 PDT
Created attachment 608341 [details] [diff] [review]
Add directory check in three places

This patch adds a check for the existence of the profile directory in three places.

This handles:

1. Directory not available when there is only one profile.
2. Directory not available when explicitly specified on the command line
3. Directory not available when the profile is selected in the profile dialog.

In all cases, I added this check before the lock dialog was about to display, so this will not affect startup.
Comment 128 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-04-03 10:48:52 PDT
bsmedberg, any chance you'll have a chance to look at this?

I'd like to try to get it into the next build since it's causing issues for some work I'm doing.
Comment 129 Dietrich Ayala (:dietrich) 2012-04-10 09:20:06 PDT
bsmedberg said it's on his list, but not at the top of the queue. He's ok with Dolske or Mossop reviewing this instead.
Comment 130 Benjamin Smedberg [:bsmedberg] 2012-04-18 13:41:18 PDT
Comment on attachment 608341 [details] [diff] [review]
Add directory check in three places

ok, this seems to be bypassing all the hot codepaths (where we don't want to be calling Exists() if we can help it). So I think that's ok. I wonder if we should be providing the actual directory name in the dialog... oh well, this is good enough for now.
Comment 131 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-18 15:55:34 PDT
This needs approval if you want it landed for Firefox 14.  Otherwise, we can land it on the Birch branch.
Comment 132 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-04-18 17:27:24 PDT
Comment on attachment 608341 [details] [diff] [review]
Add directory check in three places

Review of attachment 608341 [details] [diff] [review]:
-----------------------------------------------------------------

Requesting approval for mozilla-central.

This is desktop only and has quite a few dupes.

We have an app that would like to have it because it will help us diagnose some profile problems we're having.
Comment 133 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-19 12:41:31 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d665f2ad8a78
Comment 134 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-20 10:33:38 PDT
https://hg.mozilla.org/mozilla-central/rev/d665f2ad8a78
Comment 135 Philip Chee 2012-04-30 10:42:03 PDT
https://hg.mozilla.org/mozilla-central/rev/d665f2ad8a78#l1.16
How do you expect this to work since gPromptService was replaced with Services.prompt in Bug 714606? Did anyone bother to test this patch?
Comment 136 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-04-30 10:48:41 PDT
> Did anyone bother to test this patch?

Yes. Unfortunately it was tested on March 22.

And because the patch was self contained, it applied clean.

I'll post a new patch for that part.
Comment 137 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-05-01 07:02:23 PDT
Created attachment 619914 [details] [diff] [review]
Fix for gPromptService problem

[Approval Request Comment]
This patch crossed with 714606 which was the removal of gPromptService
As a result, part of the patch fails.
If declined, if a user hits this scenario, they will get no prompt at all
Little to no risk patch.
Comment 138 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-05-04 07:36:20 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/ec8dbe9d9a32
Comment 139 :Ehsan Akhgari (busy, don't ask for review please) 2012-05-04 13:40:04 PDT
https://hg.mozilla.org/mozilla-central/rev/ec8dbe9d9a32
Comment 140 Paul Silaghi, QA [:pauly] 2012-05-07 01:12:23 PDT
So now the user knows that "Your firefox profile cannot be loaded. It may be missing or inaccessible". But how does this solve the problem? Firefox is still not able to start. Wouldn't be possible to automatically create a default profile and also notify the user about this?
Comment 141 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-05-07 12:01:35 PDT
> Wouldn't be possible to automatically create a default profile and also notify the user about this?

That's really not feasible. There are many reasons for this error. Network drive no longer there, USB drive no longer there, read error on hard drive, data corruption, etc. etc.

If you want to continue this discussion, please open another bug. That discussion does not belong here.
Comment 142 Vadim Rapp 2012-05-07 12:10:52 PDT
(In reply to Paul Silaghi [QA] from comment #140)
> So now the user knows that "Your firefox profile cannot be loaded. It may be
> missing or inaccessible". But how does this solve the problem? 

The user will use the information from the error message to troubleshoot the problem, as with any other problem. Specifically, he will go to the location of his user profile and check if it's really missing or inaccessible.

The only wish here is that the error message might assist in this by telling the expected location of the profile - since by all means the user will need it, and it's probably very easy to insert in the message.
Comment 143 Mike Kaply [:mkaply] (Out June 27-July 5) 2012-05-07 12:35:58 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/d6a46f18cc6a
Comment 144 Paul Silaghi, QA [:pauly] 2012-05-08 00:04:06 PDT
(In reply to Vadim Rapp from comment #142)
> The only wish here is that the error message might assist in this by telling
> the expected location of the profile - since by all means the user will need
> it, and it's probably very easy to insert in the message.

Sounds good to indicate the location of the profile. New bug 752822 filed.
Comment 145 Paul Silaghi, QA [:pauly] 2012-05-08 04:55:36 PDT
Marking this as verified fixed on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120507 Firefox/14.0a2
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20120507 Firefox/14.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20120507 Firefox/14.0a2
Comment 146 VanillaMozilla 2012-05-08 06:28:11 PDT
(In reply to Paul Silaghi [QA] from comment #145 and Michael Kaply from comment #143)
> Marking this as verified fixed on:
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120507 Firefox/14.0a2...

Thanks, but what about Thunderbird?  (See comment #0.)
Comment 147 Paul Silaghi, QA [:pauly] 2012-05-08 07:28:34 PDT
This is also verified fixed on Thunderbird 14.0a2 (2012-05-07) on Win 7 64-bit, Ubuntu 11.10 and Mac OS X 10.6. "Your Thunderbird profile cannot be loaded. It may be missing or inaccessible" error message is displayed.
Comment 148 Matthias Versen [:Matti] 2012-05-09 15:19:32 PDT
*** Bug 753446 has been marked as a duplicate of this bug. ***
Comment 149 [:Aleksej] 2013-04-30 07:05:56 PDT
*** Bug 639307 has been marked as a duplicate of this bug. ***
Comment 150 Wayne Mery (:wsmwk, NI for questions) 2014-08-10 20:54:59 PDT
*** Bug 652340 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.