when sorting threads by date, use most recent message

RESOLVED DUPLICATE of bug 262319

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 262319
14 years ago
14 years ago

People

(Reporter: cwiebe, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When sorting messages grouped by thread and sorted by date, I would prefer the
date of the last message in the thread (most recent) to be used, rather than the
first message (earliest) as it does now.

E.g. I have a thread of a conversation from two weeks ago. The date of that
thread is considered the date of the original message.  The thread has since
scrolled way out of view in my inbox.  Now, two weeks later, a new message comes
in and gets added to that thread.  At first glance I see no message in my inbox,
so I assume it's part of a thread.  I have to keep scrolling back and playing
'Where's Waldo' to find my new message.  It's very annoying.

So what I would like is to have the entire thread resorted using the date of the
newest message.  In the example above, when the new message comes in the thread
that was dated two weeks ago would get moved down and show up at the bottom of
my inbox (and would be marked to indicate the thread contains a new message).


Reproducible: Always

Steps to Reproduce:
display message threads, sort by date column

Comment 1

14 years ago
Do you mean when the new message arrives, you want the threads to jump around?
Or when you open the folder, and we resort, that's the way you want the sorting
to be? Because I believe the latter works as you want - we do keep track of the
newest message in the thread, and use that as the thread date, when sorting
threads by date.

If you want the threads with the newest messages at the top of the thread pane,
just click on the thread header again (the little icon at the top left of the
thread pane) - that will sort the threads by the date of the newest message in
the thread, so that they're at the top of the thread pane.

Comment 2

14 years ago
(In reply to comment #1)
> Do you mean when the new message arrives, you want the threads to jump around?

Bug 262319 -- if that's what's intended here, please mark this bug as a 
duplicate of that.
(Reporter)

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 262319 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.