base64 encoded mail not being decoded due to missing Content-Type

RESOLVED DUPLICATE of bug 230377

Status

RESOLVED DUPLICATE of bug 230377
14 years ago
11 years ago

People

(Reporter: etienne.stanus, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041217

this file
--- begin of eml file dump ----
X-UIDL: 10032
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Return-Path: <cyrus@mail.chu-tivoli.be>
X-Sieve: cmu-sieve 2.0
Return-Path: <root@localhost.localdomain>
Received: from vmtfimout.chu-tivoli.be (unknown [192.168.3.2])
	by mail.chu-tivoli.be (Postfix) with SMTP id A578C5BA84
	for <informatique@chu-tivoli.be>; Tue, 18 Jan 2005 07:53:23 +0100 (CET)
Received: from localhost.localdomain ([192.168.4.1])
 by vmtfimout.chu-tivoli.be (SMSSMTP 4.0.0.59) with SMTP id M2005011807595906728
 for <informatique@chu-tivoli.be>; Tue, 18 Jan 2005 07:59:59 +0100
Received: from localhost.localdomain (Cerbere [127.0.0.1])
	by localhost.localdomain (8.12.5/8.12.5) with ESMTP id j0I700jE020995
	for <informatique@chu-tivoli.be>; Tue, 18 Jan 2005 08:00:00 +0100
Received: (from root@localhost)
	by localhost.localdomain (8.12.5/8.12.5/Submit) id j0I700gm020993
	for informatique@chu-tivoli.be; Tue, 18 Jan 2005 08:00:00 +0100
Date: Tue, 18 Jan 2005 08:00:00 +0100
From: root <root@localhost.localdomain>
Message-Id: <200501180700.j0I700gm020993@localhost.localdomain>
To: informatique@chu-tivoli.be
Subject: Time Server Check on Cerbere (172.16.9.200:123).
Content-Transfer-Encoding: base64

VHVlIEphbiAxOCAwODowMDowMCBDRVQgMjAwNQ0KVGltZSBzZXJ2ZXIgaXMgT0suDQoNCg0K
DQotLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0t
LQ0KQ2UgbWFpbCBuZSBjb250aWVudCBwYXMgZGUgVmlydXMgZOl0ZWN06SBwYXIgU3ltYW50
ZWMgTWFpbA0KU2VjdXJpdHku



---end of eml file dump ----

display as 
VHVlIEphbiAxOCAwODowMDowMCBDRVQgMjAwNQ0KVGltZSBzZXJ2ZXIgaXMgT0suDQoNCg0K
DQotLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0t
LQ0KQ2UgbWFpbCBuZSBjb250aWVudCBwYXMgZGUgVmlydXMgZOl0ZWN06SBwYXIgU3ltYW50
ZWMgTWFpbA0KU2VjdXJpdHku

in Mozilla mail windows
however it is correctly interpreted both on 
- "horde" web display while on a cyrus server
- outlook 
where it is seem as :


Tue Jan 18 08:00:00 CET 2005
Time server is OK.



-----------------------------------------------------
Ce mail ne contient pas de Virus détecté par Symantec Mail
Security.



  

Reproducible: Always

Steps to Reproduce:
1.  just have to get this kind of message
2.
3.

Actual Results:  
display as 
VHVlIEphbiAxOCAwODowMDowMCBDRVQgMjAwNQ0KVGltZSBzZXJ2ZXIgaXMgT0suDQoNCg0K
DQotLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0t
LQ0KQ2UgbWFpbCBuZSBjb250aWVudCBwYXMgZGUgVmlydXMgZOl0ZWN06SBwYXIgU3ltYW50
ZWMgTWFpbA0KU2VjdXJpdHku


Expected Results:  
should be displayed as
ue Jan 18 08:00:00 CET 2005
Time server is OK.
Component: MailNews: Main Mail Window → MailNews: Backend
Product: Mozilla Application Suite → Core
Summary: Some mails does not decode → base64 encoded mail not being decoded
Version: unspecified → Trunk

Comment 1

14 years ago
Reproduced with TB 1.0, Win2K.

This is apparently due to the missing Content-Type header.  If you add a header 
like:
  Content-Type: text/plain
the message displays as expected (at least if Western character encoding is the 
default for your configuration).

Per RFC 2045  <http://rfc.net/rfc2045.html#s5.2> , the default for Content-Type 
should be:
  Content-type: text/plain; charset=us-ascii

However, even if an explicit "us-ascii" is included in a Content-Type header 
added to the sample ISO-8859-1 message, it is displayed as expected.

xref bug 155537
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Server 2003 → All
Hardware: PC → All
Summary: base64 encoded mail not being decoded → base64 encoded mail not being decoded due to missing Content-Type

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 230377 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.