bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

microsoft.com - Sample code in Microsoft knowledge base article is rendered without line breaks

VERIFIED DUPLICATE of bug 255117

Status

Tech Evangelism Graveyard
English US
VERIFIED DUPLICATE of bug 255117
14 years ago
3 years ago

People

(Reporter: Wan-Teh Chang, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
The Microsoft knowledge base article
http://support.microsoft.com/?id=224282
contains sample code in a <pre></pre>
block.  Firefox 1.0 and Mozilla 1.7.1
render that code snippet without line
breaks.  Internet Explorer renders the
code snippet correctly.
The markup is:

<pre class="code">...
code snippet...
</pre>


The style (http://support.microsoft.com/common/css/default/xmlContent.css?1):

.kb div pre
{
	color: Maroon;
	background-color: #eeeeee;
	padding: 0.5em;
	margin: 1em;
	font-family: "courier new", courier, monospace;
	overflow: auto;
	width: 100%;
	white-space: normal;
}

Mozilla does the right thing since they specified "white-space: normal".

-> TE
Assignee: nobody → english-us
Component: Layout → English US
OS: Windows XP → All
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Hardware: PC → All
Summary: Sample code in Microsoft knowledge base article is rendered without line breaks → support.microsoft.com - Sample code in Microsoft knowledge base article is rendered without line breaks
Version: Trunk → unspecified

Comment 2

14 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new


*** This bug has been marked as a duplicate of 255117 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: support.microsoft.com - Sample code in Microsoft knowledge base article is rendered without line breaks → microsoft.com - Sample code in Microsoft knowledge base article is rendered without line breaks
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.