Web pages prepared in Microsoft FrontPage 2002 display table boundaries

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: haldwest, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050118 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050118 Firefox/1.0+

When looking at websites developed in Microsoft FrontPage 2002 the divisions
between tables are actively displayed in Firefox. I do not have this problem in
Internet Explorer or in Opera.

Reproducible: Always

Steps to Reproduce:
1. Open the website.
2.
3.

Actual Results:  
The borders that should be invisible are displayed.

Expected Results:  
Not show the borders

Updated

14 years ago
Version: unspecified → Trunk

Comment 1

14 years ago
You have 

<table 
	border="1" 
	cellpadding="0" 
	cellspacing="0" 
	style="border-collapse: collapse; border-width: 0" 
	bordercolor="#111111" 
	width="878" 
	height="710"
>

How did you you expect a table with border="1" to render? This is not
a FrontPage bug, but the report would seem to be WFM and INVALID.

Comment 2

14 years ago
But interestingly, Opera renders just like IE.
Maybe our quirks mode is different from them?

Which of the two is more important?
- style="border-collapse: collapse; border-width: 0"
- border="1"

If the first one is, then should be borderless.
If the second one if, then should have a border...

Comment 3

14 years ago
not firefox i think. Moving to Core
Assignee: firefox → roc
Component: General → Layout: View Rendering
Product: Firefox → Core
QA Contact: general → ian

Updated

14 years ago
Assignee: roc → nobody
Component: Layout: View Rendering → Layout: Tables
QA Contact: ian → layout.tables

Comment 4

14 years ago
http://www.w3.org/TR/REC-html40/struct/tables.html#adef-border-TABLE
  * Setting border="0" ...
  * Other values of border imply frame="border" and, unless otherwise
    specified, rules="all".

http://www.w3.org/TR/REC-html40/struct/tables.html#adef-rules
  * all: Rules will appear between all rows and columns.

Note "between".

http://www.w3.org/TR/CSS21/cascade.html#specificity
6.4.3: "In HTML, values of an element's "style" attribute are style sheet rules.
These rules have no selectors, so a=1, b=0, c=0, and d=0."

6.4.4: "The UA may choose to honor presentational attributes in an HTML source
document. If so, these attributes are translated to the corresponding CSS rules
with specificity equal to 0, and are treated as if they were inserted at the
start of the author style sheet."

So the table itself should not have a border (border-width:0 "wins").
AFAICT, the rendering is correct.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 5

14 years ago
(In reply to comment #4)
> So the table itself should not have a border (border-width:0 "wins").
> AFAICT, the rendering is correct.
> 
> -> INVALID


Just to clear up some confusion: Mats, you say it should NOT have a border, but
the reporter says we DO render a border?

Comment 6

14 years ago
(In reply to comment #5)

Yes, we do have borders /inside/ the table, because of the implicit rules="all"
and we should render those borders because CSS table{border-width:0} only
affects the border surrounding the table element itself, not the borders on
children.
You need to log in before you can comment on or make changes to this bug.