Plain text reply quotes are not wrapped at defined width in message composer

RESOLVED DUPLICATE of bug 196033

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 196033
13 years ago
13 years ago

People

(Reporter: Ville Mattila, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I've defined a wrapping to be used when composing a plain text messages. For
some reason, when I click reply button Thunderbird and an unwrapped previous
message will be quoted in the reply, the wrapping preferences don't affect it
and the quote will be written as in the message source.



Reproducible: Always

Steps to Reproduce:
1. Reply to any unwrapped plain text message

Actual Results:  
The message quote will not be wrapped as it should regarding the composing
preferences.

Expected Results:  
Reply should be wrapped in the defined width and quote marks (>) added in front
of each line.
(Reporter)

Comment 1

13 years ago
Created attachment 171725 [details]
Message composer with quotes unwrapped

Comment 2

13 years ago
If the original message is text/plain without format=flowed, then yes, we do not 
automatically wrap the quoted text.  This is deliberate; see the duplicate.

We also do not wrap quoted HTML text that appears within a <pre> block, for the 
same reason.



*** This bug has been marked as a duplicate of 196033 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.