Closed Bug 278968 Opened 20 years ago Closed 20 years ago

Cannot save web pages with embeded pictures as a single file

Categories

(Firefox :: File Handling, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 18764

People

(Reporter: tonycurtisjr, Assigned: bugs)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Dear Sirs,

We have tested Firefox 1.0 <http://www.mozilla.org/products/firefox/> on Mac OS
X 10.3.7.

We want to deploy Firefox at our University, but for that we need it to save
pages also as "Web Archive" with all images self-contained in the same web page
(as Internet Explorer 5.2.3 does).

The option to save as "Web Archive" is missing in the current version of
Firefox. It saves the "Web page, Complete" as one file and the pictures on a
separate folder (much as Netscape 7.2 does). That is great sometimes, but we
need also the other option indicated above.

If possible, please implement such useful feature. We need it to save web pages
with self-contained pictures for future reference, lecturing and research at our
University. This is a must for us. We cannot afford to use Firefox until this
feature is implemented.

Once you implement such feature, we will make the switch to Firefox.

Thank you.
Sincerely,

Reproducible: Always

Steps to Reproduce:
1.See above.
2.
3.

Actual Results:  
See above

Expected Results:  
See above

See above.
See Bug 275302 "allow saving and viewing mht and war files"

Dup of Bug 18764 "Full rfc2557 MHTML multipart/related support in BROWSER"

If you ask nicely, you find that you have a lecturer or researcher
who is prepared to read the Bug 18764 and perhaps implement part or all
of it.
*** Bug 278969 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 18764 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
http://maf.mozdev.org/ might be of interest, although this isn't an official
solution.
You need to log in before you can comment on or make changes to this bug.