Closed Bug 278988 Opened 15 years ago Closed 15 years ago

XPI Install should support wildcard domains and 'install once'

Categories

(Toolkit :: Add-ons Manager, enhancement)

enhancement
Not set

Tracking

()

VERIFIED DUPLICATE of bug 252830

People

(Reporter: mozilla.dev, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.8b) Gecko/20050118 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.8b) Gecko/20050118 Firefox/1.0+

1. The Exception list for sites allowed to install software should support
wildcards on domains, this would avoid the need to have
autofill.mozdev.org, cute.mozdev.org etc. rather just have *.mozdev.org. Support
for directories as well might be useful (e.g. mozdev.org/somedirectory)

2. The banner bar (apologies for the bad term) that shows when an install is
blocked currently only has an edit options button to add the site, it would be
very useful and more secure to allow a "allow this time only". This is useful
when downloading from a site on a public hosting server that has other sites on
the same domain and you don't want to trust all sites especially all the time.

Reproducible: Always
Don't file two issues in a bug, please.

1:
IIRC, we don't need wildcard, "mozdev.org" should
work. "addons.update.mozilla.org" didn't exist
when mozilla.org released Firefox 1.0 .
"update.mozilla.org" is white-listed by default.

I think this is ->WONTFIX

2:
A duplicate of bug 252830
Component: Download Manager → Extension/Theme Manager
OS: Windows XP → All
Hardware: PC → All

*** This bug has been marked as a duplicate of 252830 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.