Need friendly HTTP error pages (404 and such) for UMO

RESOLVED DUPLICATE of bug 278965

Status

addons.mozilla.org Graveyard
Public Pages
--
enhancement
RESOLVED DUPLICATE of bug 278965
14 years ago
2 years ago

People

(Reporter: Alex Sirota (iosart), Assigned: alanjstr)

Tracking

unspecified
x86
Windows XP

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Right now, the 404 error is shown as: (https://addons.update.mozilla.org/wrongurl)
--------------
Not Found

The requested URL /wrongurl was not found on this server.
Apache/2.0.46 (Red Hat) Server at addons.update.mozilla.org Port 8080
--------------

The server should present a user friendly page, explaining what happened and
what the user can do - a search box for extensions/themes etc.
The page has to be styled with the UMO style.

The main mozilla.org error pages are much better in this respect:
http://www.mozilla.org/wrongurl




Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 278965 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.