Control-A and ctrl-T affect view setting when view field is focused - ctrl is ignored / hotkeys also fail

RESOLVED FIXED in Thunderbird 3.0a3

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED FIXED
14 years ago
8 years ago

People

(Reporter: Robert Harvey, Assigned: clarkbw)

Tracking

({dataloss})

Trunk
Thunderbird 3.0a3
dataloss
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Thunderbird version 1.0 (20041206)

A difficult one to describe, I'll try the step by step box.  My pop3 server was
recently reset by the provider, so all my stored messages were fetched again by
Thunderbird leading to lots of duplicates.

In an attempt to remove the duplicates I used 'view unread' to only display the
new versions, then used ^A and the delete icon to trash them.  Then when I
switched back to 'view all' the inbox was empty - all the contents of the inbox
had been moved.

Reproducible: Always

Steps to Reproduce:
1.  Have some unread messages in inbox
2.  Select 'view unread'
3.  select all 
4.  delete

Actual Results:  
every message from the inbox was moved to the trash folder, including the ones
previously read and not displayed.

Expected Results:  
only moved the unread messages to trash, because those were the only ones on
view and hence susceptible to selection.

Comment 1

14 years ago
confirming and taking - that's ugly. I wonder if quick search has the same
problems (I don't think it does)
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Selection problems when view is not set to 'all' → Select all ignores view setting

Comment 2

14 years ago
Interestingly, if I use the same MailView, but instead of Delete, I mark the 
selected messages with a Flag, only the ones that are visible get flagged.

Comment 3

14 years ago
This bug could well cause data-loss, if people are not aware of the "extra" 
deleted messages. I think it should be marked as "blocking".
(Reporter)

Comment 4

13 years ago
Has this been fixed yet?

Comment 5

13 years ago
While the focus is *on* the mailview, the 'A' is grabbed without regard to 
the Ctrl modifier; and the 'A' is interpreted as the first letter in the 
"All" MailView.

Workarounds are: move the focus to the thread pane before typing Ctrl-A, 
or use Edit|Select All, or use the shift-clicking with the mouse to select.

This is Seamonkey bug 75587.
OS: Windows XP → All
Hardware: PC → All
Summary: Select all ignores view setting → Control-A resets view setting to All (when focused)
Version: 1.0 → Trunk

Comment 6

13 years ago
*** Bug 315725 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
more pervasive than just control-A
Summary: Control-A resets view setting to All (when focused) → Control-A and ctrl-T affect view setting when view field is focused

Comment 8

13 years ago
*** Bug 317896 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
howdy y'all,

my tb info ...
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051201 Thunderbird/1.5 - Build ID: 2005120115

this is NOT limited to just trunk. happens with new, clean install of tb150 final with a new, clean profile. lookee ...

- TB1.5 bug? When View:Unread is selected and Ctrl+A is hit...
http://forums.mozillazine.org/viewtopic.php?t=370571

take care,
lee

Comment 10

13 years ago
(In reply to comment #3)
> This bug could well cause data-loss, if people are not aware of the "extra" 
> deleted messages. I think it should be marked as "blocking".

I absolutely agree! This bug is potentially very dangerous.

It is even worse if people have set TB to empty their Trash folder on exit. Imagine what will happen if they have moved all their messages from the Inbox folder to the Trash without noting.

Comment 11

13 years ago
> I absolutely agree! This bug is potentially very dangerous.

Yup I have lost all my Inbox 3 times  before I worked out what was going on.  

It's second nature for me to select all junk, ctrl-A, del, compact folder...

Comment 12

12 years ago
(In reply to comment #5)
> While the focus is *on* the mailview, the 'A' is grabbed without regard to 
> the Ctrl modifier; and the 'A' is interpreted as the first letter in the 
> "All" MailView.

happens for any ctrl modified key where key matches the first letter of an item in mailview - for example ctrl-s and ctrl-c (save and customize respectively)
Severity: normal → major
Summary: Control-A and ctrl-T affect view setting when view field is focused → Control-A and ctrl-T affect view setting when view field is focused - ctrl ignored

Updated

12 years ago
Duplicate of this bug: 325050

Updated

12 years ago
Duplicate of this bug: 352031

Updated

12 years ago
Duplicate of this bug: 326129
QA Contact: front-end

Comment 16

11 years ago
For details of a hack that seems to fix this, see: http://forums.mozillazine.org/viewtopic.php?p=2971218#2971218

Comment 17

11 years ago
== suite bug 191801
Depends on: 191801
Summary: Control-A and ctrl-T affect view setting when view field is focused - ctrl ignored → Control-A and ctrl-T affect view setting when view field is focused - ctrl is ignored / hotkeys also fail

Updated

11 years ago
Duplicate of this bug: 405597

Updated

11 years ago
Duplicate of this bug: 417454
Flags: blocking-thunderbird3?

Updated

10 years ago
Keywords: dataloss
david, I wonder if the hack described in comment #16 is a worthy proto-patch.

marking as blocking because of the dataloss.
Flags: blocking-thunderbird3? → blocking-thunderbird3+

Comment 21

10 years ago
phil might have an idea - I don't think we can change the global menulist.xml that way. I tried to quickly add an onkeypress handler to our view menu in mailWindowOverlay.xul but it didn't seem to help.
Hmm. Looks to me like (most of) the dataloss aspect was fixed by bug 385374 - the menulist will eat keypresses without respecting modifiers, but will also preventDefault, so ctrl+a will switch you to All, but not select anything.

However, it seems like a menulist bug that ctrl+a is handled by the menulist - HTML selects don't work that way (focus this bug's Product select, and while s takes you to Sumo, ctrl+s wants to save the page), and bug 403210 comment 14 makes it sound like Neil was expecting menulists to not do anything when any of ctrl/alt/meta were used.
(Assignee)

Updated

10 years ago
Assignee: bienvenu → clarkbw

Comment 23

10 years ago
compose window, from: field is also afflicted, if you have a name in their that starts with a "W" (of which I have several)

Comment 24

10 years ago
Bug 403210 didn't fix this because modifiers is ignored if you don't specify a key. Oops.

Updated

10 years ago
Depends on: 400854
No longer depends on: 191801

Comment 25

10 years ago
=> fixed by bug 400854.
someone should check the SM bug.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
You need to log in before you can comment on or make changes to this bug.