Quote characters are not allowed in the default emailregexp

RESOLVED DUPLICATE of bug 415658

Status

()

Bugzilla
User Accounts
--
minor
RESOLVED DUPLICATE of bug 415658
14 years ago
6 years ago

People

(Reporter: Jon Schewe, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)
Build Identifier: 

SMTP addresses are allowed to have single quote characters (') before the @ in 
an email address.  I have such a user and this bug was fixed in 2.16, but 
seems to be not allowed in 2.18 by default.  Could the default be changed? 

Reproducible: Always

Comment 1

14 years ago
SMTP addresses are allowed to have a LOT of things in them that they really
shouldn't have. :-)

However, I suppose people should be allowed to do what they want to do...

What's the error that you get? I don't see any checkins on editparams that
should cause that problem:

<http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/webtools/bugzilla/editparams.cgi&root=/cvsroot>
OS: Linux → All
Hardware: PC → All
Version: unspecified → 2.18
(Reporter)

Comment 2

14 years ago
This shows up during a sanity check.  When I run the sanity check against my 
old database I get an error that the email address is invalid.  When I checked 
the default emailregexp I found that it doesn't allow single quotes.  This 
comes into play when working with people from Ireland. 

Comment 3

13 years ago
*** Bug 281958 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
We can reproduce this problem at bugzilla.novell.com (bugzilla 2.20). A possible fix is to change emailregexp from this:

^[\\w\\.\\+\\-=]+@[\\w\\.\\-]+\\.[\\w\\-]+$

to this:

^[\\w\\.\\+\\-=\']+@[\\w\\.\\-]+\\.[\\w\\-]+$

The fix would actually be in defparams.pl, not editparams.cgi

Updated

10 years ago
Duplicate of this bug: 465248

Comment 6

6 years ago
Fixed in Bugzilla 5.0.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415658
You need to log in before you can comment on or make changes to this bug.