"Display Messages Using Fixed-Width Font" Doesn't

RESOLVED DUPLICATE of bug 144230

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 144230
13 years ago
8 years ago

People

(Reporter: Jerry Baker, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
20050117 trunk

Setting the preferences to display messages using a fixed-width font doesn't
work. Tabs do not line up in the message display, but they do line up in view
source.
(Reporter)

Comment 1

13 years ago
Created attachment 171788 [details]
Screenshot

The top portion is the source of the message, and the bottom is the actual
display of the message. Note the misalignment of tabs in the actual message
display.
(Assignee)

Comment 2

13 years ago
is this a regression from 1.0 or was the problem in 1.0 too?
(Reporter)

Comment 3

13 years ago
Actually, this has been a problem for as long as I can remember.
(Q1) What font is set as "Monospace:" font in Tools/Options/Font settings?
     Check for at least "Fonts for: Western" and "Fonts for: your language".
(Q2) The screen shot is plain text mail? Or a part of HTML mail?
     What is the charset of the mail?
     What is your View/"Message Body as" setting?
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> (Q1) What font is set as "Monospace:" font in Tools/Options/Font settings?

Courier New (Default)

>      Check for at least "Fonts for: Western" and "Fonts for: your language".

The language and scripts are set correctly.

> (Q2) The screen shot is plain text mail? Or a part of HTML mail?

Plain-text

>      What is the charset of the mail?

ISO-8859-1

>      What is your View/"Message Body as" setting?

Original HTML (Default)
(In reply to comment #5)
Both screen shots look display with "Courier New"(not font related problem).
Different number of spaces is used for message source display and mail display?
Can you attach mail file for problem recreation?
 - Save the mail as ".eml"
 - Change personal or private data to dummy data
   (eg. replace mail address by xxx@aaa.bbb.ccc)
 - Attach the file to this bug as "text/plain"
(Reporter)

Comment 7

13 years ago
Created attachment 171928 [details]
Message

This is the message in question. The file is saved the same way it is
displayed.
(Reporter)

Comment 8

13 years ago
I think the bug may be that Thunderbird is converting the tabs to spaces for
display. You can tell by highlighting a line of tabs. Then try the same thing in
View Source.

Comment 9

13 years ago
Everything mentioned so far I can reproduce in Tb 1.0
(In reply to comment #7)
> Created an attachment (id=171928) [edit]
Message source display probably uses "8 spaces per tab".
Mail display is probably uses "4 spaces per tab".
(Almost same result when "8 spaces per tab" case and "4 spaces per tab" case on
my text editor.)

Discrepancy between message source display and mail display can be avoided by
using same "spaces per tab".
But there is no standard for number of spaces per tab.
In your case, mail sender probably uses "8 spaces per tab", then "message source
display" is as expected.
But if mail sender uses "4 spaces per tab", "mail display" is the expected display.
(My text editer's default is "4 spaces per tab".)
Therefore, "spaces per tab" option will be required to display tabbed text as
expected.
Is it really needed as mailer's standard function?
I think copy&paste to advanced text editor is sufficient, although I don't deny
enhancement request.
This is similar problem to Bug 144230.
> Bug 144230 : TAB stops inconsistent in compose window (8 space stops) and read
window (just 4 spaces for flowed display)

Adding spaces for tab character in composing was done by Bug 23547.
> Bug 23547 : tab should insert spaces
(Reporter)

Comment 12

13 years ago
This is a message I composed with Thunderbird. If it looks one way while
composing, it should look the same while reading.
(Reporter)

Comment 13

13 years ago
I'm going to mark this as a duplicate. It's the same bug.

*** This bug has been marked as a duplicate of 144230 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.