search engine duplicates added automatically

RESOLVED DUPLICATE of bug 299825

Status

()

RESOLVED DUPLICATE of bug 299825
14 years ago
13 years ago

People

(Reporter: william, Assigned: p_ch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050112 Firefox/1.0 (Ubuntu) (Ubuntu package 1.0+dfsg.1-2ubuntu1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050112 Firefox/1.0 (Ubuntu) (Ubuntu package 1.0+dfsg.1-2ubuntu1)

I haven't figured out exactly what's going on, but after using both the google
and amazon search engines, there is a duplicate search engine installed in the
search engine drop-down list.  

At the moment, there is a google.src (no .png) in my
$HOME/.mozilla/searchplugins folder.  

I also had the Mozilla Suite installed, but it's been removed.  I couldn't add
search engines as a user, so I added engines as root, then copied the .src and
.png files to my $HOME/.mozilla/searchplugins folder keeping the root ownership
of the plugins.  I think the issue started when I did this, though I am running
Ubuntu hoary which is still in development.

I have deleted the *.src file from my searchplugins directory, but it comes
back, though not right away.

Reproducible: Sometimes

Steps to Reproduce:
1.use serach engine..
2.switch to a new search eingine
3. ????  may have to do with my daughter turning off the computer without a
proper shutdown??  Sorry, I'll keep trying to figure it out!
Actual Results:  
nothing this time..  it added a duplicate search engine before

Expected Results:  
not added the extra engine
(Reporter)

Comment 1

14 years ago
Well, it's still duplicating search engines in the toolbar.

I've upgraded to mozilla-firefox 1.0.2-0ubuntu2 with
mozilla-firefox-gnome-support 1.0.2-0ubuntu2.

1.) I cleared all the search engines out of $HOME/.mozilla/firefox/$.deafult/search

2.) Opened firefox, searched with google from the toolbar, closed firefox,
reopened, and the NEW DUPLICATE search engine (without the png file) was the new
default.

3.) Opened firefox, searched with amazon from the toolbar, closed firefox,
reopened, and the NEW DUPLICATE search engine (this time with the png file) was
the new default.

4.) I copied the messages from the terminal when firefox closes.  Don't know if
it will help or not:

Cutting log (size: 100862, max: 100000)Component returned failure code:
0x80470002 (NS_BASE_STREAM_CLOSED) [nsIFileOutputStream.write]Component returned
failure code: 0x80470002 (NS_BASE_STREAM_CLOSED)
[nsIFileOutputStream.write]Component returned failure code: 0x80470002
(NS_BASE_STREAM_CLOSED) [nsIFileOutputStream.write]Cutting log (size: 100862,
max: 100000)Error cleaning up log: Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [nsISeekableStream.seek]

Comment 2

14 years ago
A problem like this has been observed when a search plugin's update url points
to a different search plugin. Two such search plugins are included in the en-GB
release.

Firefox periodically updates its search plugins by downloading the plugin that
the update url points to. If the filename is different, it does not replace the
original and you get an extra search plugin.

It's discussed in more detail in Bug 284456

Comment 3

14 years ago
This problem also exists on the Windows machine. Probably all platforms have
this problem.

On Windows, even though there is a google searchplugin with its icon in your
Mozilla's installed directory, i.e Program Files/mozilla/firefox in my case, the
one in the C:\Documents and Settings\<user name>\Application
Data\Mozilla\Firefox\Profiles\default.gb9\searchplugins, is also displayed.
Usually the google search plugin in the Application Data directory doesn't have
its icon. Although I removed it manually, it keeps appearing.

Sometimes, as this bug's original reporter mentioned, things are installed
without users' consent.

Comment 4

14 years ago
It's doing the smae thing in Deer Park Alpha 2, on Windows 2000 and if you
accidentaly select duplicate, the icon will disappear, and only way to fix it is
to run DP in safe mode and chnage it.
I'm not too sure, but this issue should have been fixed.

*** This bug has been marked as a duplicate of 299825 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.