Closed Bug 279033 Opened 17 years ago Closed 17 years ago

bug in new message alert

Categories

(Thunderbird :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 228168

People

(Reporter: sean.neeley, Assigned: mscott)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0 (MOOX M3)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0 (MOOX M3)

In the Thunderbird options, I have the 'Show an alert' box checked for when new
messages arrive.  I also have junk mail automatically sent to a junk folder and
marked as read.  The problem is, I get at least 100 spam/junk messages a day, so
while I'm working, I constantly see the new mail indicator appear above my
system tray, and then when I go to check my mail, I find my mailbox empty. 
There is something related to this in your FAQ section.  It's very annoying and
hurts my productivity at the office.  

Anyway, my feature request, is that you do not show the new mail indicator/alert
when new mail comes in and is sent right away to the junk folder.  The new order
of operations would be:
1) fetch mail from server
2) move spam to junk folder
3) show new mail alert if message was not moved to junk folder

Thank you.

Reproducible: Always
Junk mail not be triggering the alert is current Tb behavior...

What version of thunderbird are you using?
Severity: enhancement → normal
version 1.0 - [MOOX M3] (20041208)

Do I need a newer version?
Version: unspecified → 1.0
The New Mail notification appears, and shows that there are 0 new messages. 
This is because the new mail was junk and was moved to the junk mail folder and
is no longer in my mailbox.  I don't think that I should have been notified in
this situation.
Another screen shot of the weird behavior when junk mail is moved out of my
mailbox.  Notice the tooltip text showing 0 new messages when I hover the mouse
over the New Mail icon in the system tray.
Attached image View inside my mailbox
After receiving the "0 new messages" alert, I switch over to the Thunderbird
application.  I see that the mailbox 'sen@myrealbox.com' has a decoration on
the icon indicating that I have new mail in that folder, but you can see that
the 'Inbox' folder has no new messages... if it did, it would say 'Inbox (1)'
in bold.
I also have this problem.  Only my junk mail isn't going to Junk, I've sent it
straight to Trash.  Yet, I get a notification in the task bar showing I have 0
new messages.  Looking at my mail, I see that the Trash folder is bold and has a
number after it, e.g. (1).  I right-click on Trash, and select Empty Trash. 
Then the Trash folder loses the number, but stays bold.  I then left-click on
the Trash folder, and although no messages appear in the right-hand pane, it
switches back to saying Trash (1)!  I have to click on another folder, then
click BACK on Trash to get it to finally go non-bold and just say Trash.

All this every time I get a piece of junk mail!  I wish I could just turn the
notification off completely.

Also, any time the junk mail filter or any other filter marks an incoming
message as read or sticks it in the Trash, it shouldn't trigger a notification.
Summary: feature request for new message alert → bug in new message alert
I'm guessing this is happening on an IMAP account with a Junk folder that's 
under Local Folders.  Correct?  Then this is bug 228168; please dupe it.

Are the messages going to Junk being filtered by TB's Junk Mail Controls, or by 
one or more filters of your own design?
(In reply to comment #7)
> I'm guessing this is happening on an IMAP account with a Junk folder that's 
> under Local Folders.  Correct?  Then this is bug 228168; please dupe it.

Correct!

> Are the messages going to Junk being filtered by TB's Junk Mail Controls, or by 
> one or more filters of your own design?

Thunderbird's Junk Mail controls.  Sounds like a dupe, so I will mark it as such

*** This bug has been marked as a duplicate of 228168 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Uhm... not willing to hurt someone... but I get this behaviour when filtering
junk to a remote junk folder, too.

This is new to me now. Never had the Problem with POP3. And also IMAP did really
well till today. (???) Today i got several "0 new messages" alerts on an IMAP
account with junk control filtering to IMAP junk folder (not local).

Using version 1.0+ (20050630) of Thunderbird.
i realized that sometimes junk mail is being identified as junk but not moved to
the junk folder. perhaps this is related to that. but i cannot attest that these
to events are linked.
Bug 292772 also relates on this and was marked as dup of Bug 228168. But in
228168 only the movement from IMAP to local folders is being discussed?!
You need to log in before you can comment on or make changes to this bug.