Closed Bug 279088 Opened 16 years ago Closed 16 years ago

Reply splits ISO 8859 encoded "from"

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows 2000
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: daniel.tietze, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I am regularly encountering a bug in replying to EMails sent via MS Exchange.

Here in Germany, people tend to have Umlauts in their name.
In this case, Exchange encodes the realname part of the "from" line. prefixing
it with "=?iso-8859-1?Q?" - but WITHOUT enclosing the realname part in quotes.
This is OK per the RFC, since entities enclosed in this way should be treated as
atoms, even if they are not enclosed in quotes. Thunderbird, unfortunately, does
not handle this correctly.

Say I receive an EMail fomr someone who has configured his realname to be - for
whatever reason - "Bill Müller, Darmstadt, SU2-DA55" (people have this, e.g.
when a full name and position description are plucked from a company X.500
directory).

Since "Müller" contains an Umlaut, Exchange decides it needs to encode the
"from" entry. So it sends a from line something like this:

=?iso-8859-1?Q?Bill M=FCller=2C_Darmstadt=2C_SU2-DA55?= <bill@somewhere.else>

Thunderbird now decodes this wrongly, not realising that the WHOLE thing
enclosed in =?iso-8859-1?Q? and ?= is the realname, and splits it into multiple
recipients. It treats the comma as an address delimiter, rather than as part of
the atom making up the sender's name.

This means that when I hit reply, I end up replying to multiple recipients:
Bill
Müller@mydomain.com
Darmstadt@mydomain.com
SU2-DA55@mydomain.com
bill@somewhere.else

Each time I have to go to the recipient list and remove the extra entries. 

Reproducible: Always

Steps to Reproduce:
Ger mail from some with Umlaut in name and using Exchange mail server. Reply. :-)
Looks like a duplicate of Bug 254519.
Yes, it really *is* a duplicate. Seems I didn't seach thouroughly enough.

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.