"Open in Tabs" feature has unfortunate behaviour if multiple tabs are already open

VERIFIED DUPLICATE of bug 216346

Status

()

--
critical
VERIFIED DUPLICATE of bug 216346
14 years ago
14 years ago

People

(Reporter: david.barrett, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If one opens a certain amount of tabs up in ones browser, then clicks "Open in
tabs" in any bookmark folder, the new tabs will overwrite the old ones. This
would be fine (you can just hit back on the tabs to get back to the previous
page) if the tabs that were NOT used by these new pages did not close without
warning. This is the real kicker. Users can lose their open pages without
warning. If one has had an active browser session, it's a right pain in the ass
tracking down ones pages again.

Reproducible: Always

Steps to Reproduce:
1. Open some tabs up
2. Select "Open in tabs" in any bookmark folder
Actual Results:  
Current tabs overwritten with new pages. Tabs unused by these new pages are
closed without warning, so one could potentially lose data.

Expected Results:  
I would expect a warning that my action would overwrite current tabs, closing
those tabs that are not used by new pages (I am unsure of how this should be
worded). Perhaps it should provide an option to open the new tabset in a new
browser window?

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Comment 2

14 years ago
This bug is CRITICAL! - users loose their data.
Bug exists very long time (from v0.9 as I remember), but nobody bothers about
that :(
You need to log in before you can comment on or make changes to this bug.