chromehidden attribute should be set earlier

RESOLVED DUPLICATE of bug 345560

Status

()

Core
XUL
P1
major
RESOLVED DUPLICATE of bug 345560
13 years ago
12 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

({perf})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

13 years ago
This is a followup to bug 255372.  See especially bug 255372 comment 95.

Right now we set the chromehidden attribute way too late, after we've
constructed frames and loaded images for all the chrome that's going to be
hidden.  This has two problems:
 1. We do a lot of extra work
 2. As long as onload is fired synchronously, we're breaking a bunch of
invariants by modifying the document in the middle of code that depends on the
document not being modified.  This can cause crashes like bug 255372.
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.8beta3
(Assignee)

Updated

13 years ago
Severity: normal → major
Keywords: arch, perf
Target Milestone: mozilla1.8beta3 → Future
(Assignee)

Updated

13 years ago
Keywords: arch
(Assignee)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 345560 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.