If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

50-60% CPU usage when visiting sites with scrolling text (javascript)

RESOLVED DUPLICATE of bug 137584

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 137584
13 years ago
13 years ago

People

(Reporter: token4, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050111
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050111

High CPU usage (Javascript) when visiting
http://cs.senecac.on.ca/DM/cs_builder/build_current_dm.php. On the bottom of the
page, the scrolling message (javascript) is the cause.

When Javascript is disabled for "Navigator", CPU usage drops to almost 0%. IE
doesn't seem to have this problem.

Note: Firebird seems to have the same problem, except its CPU usage stays at
around 35-45%

Reproducible: Always

Steps to Reproduce:
1.goto http://cs.senecac.on.ca/DM/cs_builder/build_current_dm.php
2.Wait for a few seconds untill the scrolling message board start to scroll
3.CPU usage stays at around 50-60%

Actual Results:  
CPU usage stays at around 50-60%

Expected Results:  
Less than 1%
(Reporter)

Updated

13 years ago
Summary: 50-60% CPU usage when visiting the above site. → 50-60% CPU usage when visiting sites with scrolling text (javascript)

Comment 1

13 years ago
token4:
if you are webmaster of such site or if you can get in touch with the site
manager, then you can notify them of cross-browser and W3C compliant
alternatives for DHTML newsticker:

Cross-browser and web standard compliant Stock Ticker example
http://web.archive.org/web/20040202191024/http://devedge.netscape.com/toolbox/examples/2001/stock-ticker/

and

Comprehensive W3C web standard compliant alternative to <marquee>
http://web.archive.org/web/20040202065251/http://devedge.netscape.com/toolbox/examples/2002/xb/xbMarquee/

The culprit is:
<script type="text/javascript">

/***********************************************
* IFRAME Scroller script- © Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Dynamic Drive at http://www.dynamicdrive.com/ for full source code
***********************************************/

found at:
http://cs.senecac.on.ca/cs_modules/rss_feeds.php

Resolving as DUPLICATE of bug 137584

*** This bug has been marked as a duplicate of 137584 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.