favicon replaced with default in location bar when tabs switched for local files -- file:///

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
trivial
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: M. Kristall, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows XP
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050120
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050120

If I open a local Web page with a specified <link rel="shortcut icon" ...,
switch to another tab, then switch back, the favicon in the location bar goes
back to the default.

Reproducible: Always

Steps to Reproduce:
1. Open a local file with specified favicon in a tab
2. Switch tabs
3. Switch back

Actual Results:  
Page's favicon is replaced with the default favicon in the location bar.

Expected Results:  
The page's specified favicon should refresh / come back.

I'm not sure if this could be considered a duplicate of another bug. There are
so many favicon-related bugs that are similar, but since I'm not a Mozilla
developer I'm not sure. (To the best of my knowlege, none of the similar ones
were identical.)

Comment 1

13 years ago
I can reproduce this bug with both remote (http://) and local (file:///) URLs,
related to Firefox bug 253542?
Version: unspecified → Trunk
I suspect this may have been fixed by the checkin for bug 289609.
Keywords: qawanted

Comment 3

13 years ago
I can reproduce this with 1.8b, but http:// URLs are also affected.  Both work
with current trunk (2005041705).

M. Kristall: Can you reproduce this bug with a recent nightly?  Are you sure the
same behavior doesn't exist with http:// URLs?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> I can reproduce this with 1.8b, but http:// URLs are also affected.  Both work
> with current trunk (2005041705).
> 
> M. Kristall: Can you reproduce this bug with a recent nightly?  Are you sure the
> same behavior doesn't exist with http:// URLs?

Works for me now with Firefox 1.0.3 and 2005041905. So no I can't reproduce it.
(I was pretty sure at the time it didn't work with remote file though...)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.