Slow resizing of browser window with transparent images as background in css.

RESOLVED DUPLICATE of bug 64401

Status

()

RESOLVED DUPLICATE of bug 64401
14 years ago
14 years ago

People

(Reporter: uruviel, Assigned: pavlov)

Tracking

({qawanted, testcase})

Trunk
x86
Windows XP
qawanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050119 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050119 Firefox/1.0+

When viewing a site which uses transparent images (gifs or PNG) the resizing of
the browser window is terribly slow. I've provided a test case. But I first
experienced this problem with: http://www.uruviel.com/test/

Reproducible: Always

Steps to Reproduce:
1.Open a site which uses transparent images as background
2.Resize the browser window
3.

Actual Results:  
The resizing is slower then normal
(Reporter)

Comment 1

14 years ago
Created attachment 171993 [details]
Testcase HTML
(Reporter)

Comment 2

14 years ago
Created attachment 171994 [details]
testcase image for HTML file
(Reporter)

Comment 3

14 years ago
Comment on attachment 171993 [details]
Testcase HTML

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Testcase</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css">
<!-- 
ul {
	list-style-type:none;
	padding: 0; margin: 0;
}
ul li {
	height: 281px; width: 207px;
	float: left;
}
ul li a {
	background:
url("https://bugzilla.mozilla.org/attachment.cgi?id=171994") no-repeat;
	display: block; width:100%; height:100%;
}
-->
</style>
</head>
<body> 
<ul> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
  <li><a href="#"> </a></li> 
</ul> 
</body>
</html>
(Reporter)

Comment 4

14 years ago
Comment on attachment 171993 [details]
Testcase HTML

><!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
><HTML><HEAD><TITLE>Testcase</TITLE>
>
><META content="text/html; charset=iso-8859-1" http-equiv="Content-Type"/>
><STYLE type="text/css">
>&lt;!-- 
>ul {
>	list-style-type:none;
>	padding: 0; margin: 0;
>}
>ul li {
>	height: 281px; width: 207px;
>	float: left;
>}
>ul li a {
>	background: url("https://bugzilla.mozilla.org/attachment.cgi?id=171994") no-repeat;
>	display: block; width:100%; height:100%;
>}
>--&gt;
></STYLE></HEAD>
>
><BODY> 
><UL> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
>  <LI><A href="#"> </A></LI> 
></UL> 
></BODY></HTML>
(Reporter)

Updated

14 years ago
Attachment #171993 - Attachment is obsolete: true
(Reporter)

Comment 5

14 years ago
Created attachment 171995 [details]
test case with working images

Sorry for the spamming. I was unaware that I should use absolute url's in the
image link

Updated

14 years ago
Keywords: testcase
Keywords: qawanted
(Reporter)

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 64401 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.