"background-position: bottom" is ignored on body element

RESOLVED INVALID

Status

()

Core
Layout: View Rendering
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Joël Kuiper, Assigned: roc)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050120 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050120 Firefox/1.0+

While applying 	"background:url("trans.gif") bottom repeat-x #ffffff;" where
trans.gif is any image with a height. Gecko just doens't position the background
at the bottom of the screen. This used to work in the 1.0final

Reproducible: Always

Steps to Reproduce:
1.apply "background-position: bottom" to body element
2.Load the page
3.

Actual Results:  
You see a small line of the background on top of the screen.

Expected Results:  
See the image on the bottom of the screen expanded to its full height.
(Reporter)

Comment 1

13 years ago
Created attachment 171997 [details]
image for testcase
(Reporter)

Comment 2

13 years ago
Created attachment 172000 [details]
testcase

please view in latest nightly and in the 1.0 final.
You can immediately see the deferent’s. I believe that the result in 1.0final
is the desired result.

Comment 3

13 years ago
*** Bug 279253 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
Not really, the BODY element does not have a height of 100% so it should not
appear at the bottom of the screen.

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

13 years ago
Applying it to the HTML or :root gives me the same problem

Comment 6

13 years ago
That is because the HTML element does not have a height of 100% as well.
(Reporter)

Comment 7

13 years ago
Yes but it still doesn't work when applying min-height: 100% or height: 100% on
the body element

Comment 8

13 years ago
Because then the BODY element will get the height of HTML element which is still
auto and not 100% ;-)

However, bugzilla is bug triaging system, not a user forum to ask questions
about CSS.
You need to log in before you can comment on or make changes to this bug.