Events misaligned to left in week view [or to right]

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
--
trivial
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Robert C. Mosher II, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20050111 Mozilla Sunbird/0.2RC2

All events I add are displayed offset slightly to the left in the week view.
That is that don't align properly with the Days grid. I have had this happend
consistently on two different machines. This bug is different from bugs 264212
and 258051, at least on the surface.

Reproducible: Always

Steps to Reproduce:
1.Add an event(s)
2.View the event in week view


Actual Results:  
The events are displayed out of alignment, specifically to the left, with the
Days grid.

Expected Results:  
It should display the events aligned with the days grid.
(Reporter)

Comment 1

14 years ago
Created attachment 172004 [details]
image of misaligned events in week view

Comment 2

14 years ago
Note that not all events are misaligned. 
I have also seen some cases where the boxes in some days are misaligned to the
right.
A daily repeating event may have progressively worse alignment from left to
right, then suddenly the last days are ok.

May be related to scrollbar visibility:  What might be happening is that when
grid is initially laid out, that triggers a background task to determine whether
the scrollbar should appear or not.  If the scrollbar visibility must change,
the grid is laid out again.  Meanwhile, the events are being laid out.  So what
can happen is the events get progressively worse from left to right (laid out
based on old grid), then suddenly are aligned again on the last few days (laid
out based on updated grid).  If the scrollbar became visible, then the grid
narrowed, and some events are too far the to the right.  If the scrollbar became
invisible, then the grid widened and the some events are too far to the left.

If the scrollbar visibility is changed and the grid layout is recomputed, need
to re-layout the events.

If that is not possible yet, temporary workaround might be to make the scrollbar
always visible.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Events misaligned to left in week view → Events misaligned to left in week view [or to right]

Comment 3

13 years ago
*** Bug 294494 has been marked as a duplicate of this bug. ***

Updated

13 years ago
QA Contact: gurganbl → sunbird

Comment 4

12 years ago
This should be fixed when the waronboxes gets finished.
Depends on: 304741
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody

Comment 6

11 years ago
WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3pre) Gecko/20070321 Calendar/0.5pre
Component: Sunbird Only → Calendar Views
QA Contact: sunbird → views
Whiteboard: [qa discussion needed]

Comment 7

11 years ago
Per Omar's comment, and several others (in QA Chat) besides, resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Whiteboard: [qa discussion needed]
You need to log in before you can comment on or make changes to this bug.