faulty automatic rename after duplicate download

RESOLVED DUPLICATE of bug 231048

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 231048
13 years ago
10 years ago

People

(Reporter: Nathan Walp, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If a file is downloaded that ends in a '-' followed by a number, and then that
file is downloaded again, the second copy is automagically saved as
file-(number+1).exe rather than file-(number)-2.ext like you would expect.  This
can be especially dangerous if that number is actually a date, so what was once
foo123-20040709.zip is now foo123-20040710.zip.

This may be related to bug 236514, but that is about overwriting the file, where
as this is about badly renaming it.

Reproducible: Always

Steps to Reproduce:
1. Download a file ending in '-' followed by a number
2. Download the same file again

Actual Results:  
foo123-20040709.zip was downloaded, and then downloaded again, but saved as
foo123-20040710.zip.

Expected Results:  
It should have downloaded one copy as foo123-20040709.zip, and either prompted
about the second copy, or downloaded foo123-20040709-2.zip

My download manager is set up to automagically download everything to the
desktop, and not to hide itself after completion.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.