URLs with correctly-escaped utf-8 unicode characters should show as unicode in the address bar

RESOLVED DUPLICATE of bug 150376

Status

()

RESOLVED DUPLICATE of bug 150376
14 years ago
14 years ago

People

(Reporter: tellme, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When typing http://technorati.com/tag/élèves in the address bar, it is changed
to  http://www.technorati.com/tag/%c3%a9l%c3%a8ves instead of remaining
http://www.technorati.com/tag/élèves in the display.

Similarly, if a link with href="http://www.technorati.com/tag/%c3%a9l%c3%a8ves"
is followed, it should display http://www.technorati.com/tag/élèves in the
address bar.

See http://gbiv.com/protocols/uri/rev-2002/rfc2396bis.html -- Safari gets this
right.



Reproducible: Always

Steps to Reproduce:
1. type http://www.technorati.com/tag/élèves in the address bar
2. press enter

or

1. make a link like <a
href="http://technorati.com/tag/%C3%A9l%C3%A8ves">élèves</a> somewhere
2. click on it


Actual Results:  
http://www.technorati.com/tag/%c3%a9l%c3%a8ves is displayed in the address bar

Expected Results:  
http://www.technorati.com/tag/élèves should be displayed in the address bar
(Reporter)

Comment 1

14 years ago
be sure to view this page in utf-8 to understand what I'm talking about! The
bugzilla page is encoded wrong ;-)

Updated

14 years ago
Summary: URLs with correctly-escaped utf-8 unicode charcters should show as unicode in the address bar → URLs with correctly-escaped utf-8 unicode characters should show as unicode in the address bar

*** This bug has been marked as a duplicate of 150376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.