"Rif:" or "R:" instead of "Re:" mess the threads' order

RESOLVED DUPLICATE of bug 29179

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 29179
14 years ago
14 years ago

People

(Reporter: Riccardo Fusaroli, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; it-IT; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win98; it-IT; rv:1.7.5) Gecko/20041110 Firefox/1.0

Thunderbird doesn't correctly order email in threads if answers are preceeded by
"Rif:" or "R:" instead than "Re:".
"Rif:" is used by Italian versions of some email client and I often find in my
inbox mail with subject similar to: "Rif: Re: Rif: Re: Sample of subject".
Then if I order mails by subject they are all messed up. Mails beginning with:
"Rif: Subject A" or "Re:Rif: Subject A" are filed by themselves, without
connection with mails beginning with "Subject A" and "Re: Subject A".
Same behavior for mails beginning with "Rif:" or "Re:Rif:".

Reproducible: Always

Steps to Reproduce:
1. Get mails with the same subject but some beginning with "R:" or "Rif:" an
other with "Re:"
2. Order Inbox by subjects

Actual Results:  
Threads are not correctly displaied.

Expected Results:  
Thunderbird should consider "Rif:" and "R:" as equivalent of "Re:"

Comment 1

14 years ago
This is (another) duplicate of bug 29179. Resolving as such.

I'll add a note to bug 29179 that Italian is another language with this problem.

*** This bug has been marked as a duplicate of 27179 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 2

14 years ago
Fix typo in bug this is resolved against.

*** This bug has been marked as a duplicate of 29179 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.