Error after updating Extensions (procedure entry point could not be located in xpcom.dll)

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: u49640, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050115 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050115 Firefox/1.0+

Firefox gave me the following error messages after installing an Extension
Update. i saw the same error after first starting the FF nightly with an 1.0
profile. (but it looks like everything works fine)

(screenshots follow soon)

Reproducible: Always
(Reporter)

Comment 1

13 years ago
Created attachment 172100 [details]
First error messsage
(Reporter)

Comment 2

13 years ago
Created attachment 172101 [details]
second error message

Comment 3

13 years ago
What "extension update"?
Severity: normal → major
Summary: Error after updateing Extensions → Error after updating Extensions (procedure entry point could not be located in xpcom.dll)
Version: unspecified → Trunk
(Reporter)

Comment 4

13 years ago
every update. 
this error was from updateing this extension http://spellbound.sourceforge.net/
through the auto Update Check.

it happened with other AutoUpdates as well

Comment 5

13 years ago
I think the problem is because of SpellBound. See
http://forums.mozillazine.org/viewtopic.php?p=1013915&highlight=trunk+spell%2A#1013915

CCing SpellBound author, in case he's interested.
The spell check libraries are different between the trunk and 1.0 release. Since
the trunk doesn't disable 1.0 extensions (e.g. 1.0+) there is no simple way to
prevent this from occuring during registration when an upgrade occurs. There are
updated libraries available on the spellbound site for trunk users. In the
extension manager you can uninstall the existing spellbound components and
install the new ones. Up until recently trunk has not been supported which was
stated on the web site. I'll add information regarding this issue as well.
(Reporter)

Comment 7

13 years ago
ok, i've installed the new extension and didnt get an error message anymore.
thanks for your help

--> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
As a side note... to lessen the likelihood of this happening in the future all
of the packages containing the spell check libraries have been repackaged with
just an install.js (the same one used in the spellcheck.xpi) and Linux / Windows
users are given instructions to install the spellcheck.xpi from ftp.mozilla.org.
This way when someone upgrades they will receive an error they can associate to
spellbound not working and won't think it is a problem specifically with
Firefox. I'll also add new error messages to the extension so the user will have
a better handle on what action should be taken to resolve this.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.