Scroll wheels scroll page *and* select options at same time

VERIFIED DUPLICATE of bug 33733

Status

()

Core
Layout: Form Controls
P3
major
VERIFIED DUPLICATE of bug 33733
18 years ago
16 years ago

People

(Reporter: djoham, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bug Helper:
User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.12-20 i686; en-US)
BuildID:    2000021510
Sorry for the crummy summary, but this one is hard to sum up in a single line.

What's happening is when the user clicks in a drop down box (created with the
HTML <SELECT SIZE=1>....</SELECT>), moves the mouse into the area where he/she
could choose one of the options and then scrolls the mouse wheel, the entire
page *including* the options scroll with the wheel. This separates the option
group from its original drop down. I'll include a screen shot and a test case to
demonstrate.

This bug may be related to bug ID 22254.

It's important to note that you have to follow the steps to reproduce exactly,
or you won't see the problem.

I only have Mozilla installed on my Linux partition at the moment. Time
permitting, I'll see if I can recreate this in Windows as well. Since I'm
suspecting this is a XUL problem, it will probably happen there as well.

Reproducible: Always
Steps to Reproduce:
1.Open test case
2.Activate drop down by clicking on down arrow
3.Select one of the options, but don't move the mouse after you do - leave it in
the drop down area.
4.Scroll the mouse wheel down

Actual Results:  The entire page will scroll with the mouse wheel. The contents
of the list box (the options) will also scroll with the page, separating them
from the original drop down box.
Expected Results:  I would desire that while mouse focus (or control focus) is
on the drop down box, the scroll wheel would take effect inside the option list
and move through the selections rather than scrolling the page. However, list
boxes in mozilla don't work that way either so that may be asking too much.

At the minimum, I would expect the same type of behavior that is seen when you
move the mouse outside of the drop down option area and use the scroll mouse. In
this case, the options list goes away the the page scrolls normally.
(Reporter)

Comment 1

18 years ago
Created attachment 5298 [details]
screen shot
(Reporter)

Comment 2

18 years ago
Created attachment 5299 [details]
test case

Comment 3

18 years ago
Reassign to XP Toolkit.
Assignee: leger → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: cbegle → paulmac

Comment 4

18 years ago
changing component to HTML Form Controls, reassigning. cc' bryner
Assignee: trudelle → karnaze
Component: XP Toolkit/Widgets → HTML Form Controls
QA Contact: paulmac → ckritzer

Comment 5

18 years ago
This sounds to me like bug 24083, which I checked in a fix for on the 17th.  Is
it still happening in current builds?

Comment 6

18 years ago


*** This bug has been marked as a duplicate of 24083 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

18 years ago
Still happening on Mozilla build 2000022308 (Feb 23rd Daily Build). RH Linux 6.1 KDE 1.1.2 I'm reopening since bug 24083 is marked as resolved fixed. Should I be re-opening that one instead?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

18 years ago
I will take a closer look at this.  I was probably over-zealous in marking it a
dup.

Comment 9

18 years ago
Setting assigned/M15, which is when I hope to have most of the mousewheel / form
control problems ironed out.
Status: REOPENED → ASSIGNED
Target Milestone: M15

Comment 10

18 years ago
Reassigning to Rod.
Assignee: karnaze → rods
Status: ASSIGNED → NEW

Comment 11

18 years ago
Oops, meant to assign to me.
Assignee: rods → bryner

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 12

18 years ago
I have reproduced this.  I also noticed that the same thing happens if you hit
down-arrow instead of moving the mousewheel.  So, reassigning this as a form
controls bug.  I'll keep up on this to make sure that the fix lets the
mousewheel behavior be correct as well.
Assignee: bryner → karnaze
Status: ASSIGNED → NEW

Comment 13

18 years ago
Assigning this to rods, since that is where karnaze had previously assigned it.
Assignee: karnaze → rods
*** Bug 32903 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

18 years ago
mass-move to M16
Target Milestone: M15 → M16
*** Bug 34861 has been marked as a duplicate of this bug. ***
*** Bug 36769 has been marked as a duplicate of this bug. ***
Upping the severity a notch, as people keep reporting this.

Gerv
Severity: normal → major

Comment 19

18 years ago
Rod, this might go away when gfx scrollbars for selects are turned on.  Do you 
have an ETA for that?
(Assignee)

Comment 20

18 years ago
I'm trying to get them turned on for M16, but it is slow going. Something is 
always cropping up with GfxScrollFrame or BoxLayout. evuaghan and I are working 
through the issues.
(Assignee)

Comment 21

18 years ago
moving bugs to M17
Target Milestone: M16 → M17

Comment 22

18 years ago
This is no longer happening for me with mousewheel scrolling, and we fixed the
keyboard case.  Marking Fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 23

18 years ago
Confirming fix on my system.



build 2000050709



Thanks

(Reporter)

Comment 24

18 years ago
This has regressed. Linux Build 2000072113. The original test case will
demonstrate the issue.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This sounds like the same issue as 33733 (this bug probably should have been
reopened instead of filing the a new one).

I've already got 33733 nominated for beta3, so do you mind if I resolve this one
as a dup?
(Reporter)

Comment 26

18 years ago
hrm.... but it's *my* bug :)

Nope, not a problem. Thanks

David

*** This bug has been marked as a duplicate of 33733 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 28

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 29

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.