Closed Bug 279397 Opened 18 years ago Closed 18 years ago

Popup with 'toolbar=no', followed by new tab makes for much confusion/data loss

Categories

(SeaMonkey :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 26353

People

(Reporter: pdbailey, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

After I open a popup to comose an email in my webmail it opens with no tollbar.
It I hit [command]-T (the keyboard shortcut for opening a new tab) I am looking
a the new tab and have no way to get back to my email without reopening the
tollbar (which most people don't know how to do).

Reproducible: Always

Steps to Reproduce:
1.Go to nytimes.com
2.open up any link titled "slide show"
3.hit [command]-T

OR

1.compse an email in a horde/IMP webmail app
2.hit [command]-T

OR

1. open any popup with toolbar=no
2. hit [command]-T
Actual Results:  
the popup with no tollbar turns blank and there is no apparent way to close it.
To make matters worse, when you try to close the window it tells you that you
are closing two tabs!

Expected Results:  
Either 

a) the new tab should refuse to open
OR
b) the toolbar should be forced open
> Steps to Reproduce:
> 1.Go to nytimes.com
> 2.open up any link titled "slide show"
> 3.hit [command]-T

> Actual Results:  
> the popup with no tollbar turns blank and there is no apparent way to close it.

Yes, there is: Ctrl+W on Windows platform and Cmd+W on MacOSX

> To make matters worse, when you try to close the window it tells you that you
> are closing two tabs!

That's because there is really 2 tabs but the window.open call removed the
toolbars (menubar, toolbar, location bar, etc...) from your default browser
interface.

> Expected Results:  
> Either 
> 
> a) the new tab should refuse to open
> OR
> b) the toolbar should be forced open

You can have absolute veto over scripts controlling toolbars in secondary
windows by setting in the about:config the user pref
dom.disable_window_open_feature.toolbar to true.
You can do the same for other toolbars or window functionalities:
dom.disable_window_open_feature.resizable to true
dom.disable_window_open_feature.scrollbars to true: the scrollbar(s) will
appear, will be rendered only if needed, only if content overflows window dimensions
dom.disable_window_open_feature.menubar to true
etc..
Properties all start with "dom.disable_window_open_feature."


*** This bug has been marked as a duplicate of 26353 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.