Creating new folder in Imap account for filtering purposes creates file in homedir of user

RESOLVED INVALID

Status

Thunderbird
Account Manager
--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: monchi, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Whenever one creates a new filter to a new folder in an imap account a new file
is created in the homedir ( instead of on the imap server ). So all mail that
are filtered get copied into the file in the user's homedirectory. This totaly
defeats the purpose of imap, which is the possibility to watch all mails ( even
those filtered ) online from any location.

Reproducible: Always

Steps to Reproduce:
1.Create new filter, select as the folder to where you want to copy the mail a
new folder.
2.
3.

Actual Results:  
Thunderbird creates new file in home directory of user, to where all filtered
mail is copied.

Expected Results:  
Mail headers of filtered mail are copied into other separate msf file. And not
offlined.

Comment 1

14 years ago
Is it a workaround to first create the folder and then create the filter?

I am certain that it works when done that way in Mozilla, we use it all the time.
(Reporter)

Comment 2

14 years ago
Please read the bug more carefully, the problem is not that the folder is no
created, the problem is that the folder is created in the wrond location. Or
even that the folder is created at all. While the filting should be done with
imap headers in .msf files, instead of oflining.

Monchi.
--
(In reply to comment #1)
> Is it a workaround to first create the folder and then create the filter?
> 
> I am certain that it works when done that way in Mozilla, we use it all the time.

Comment 3

14 years ago
I have read the bug carefully, and I know for sure that when you create the
folder first (under an IMAP account) and then select that folder as destination
for filtering, it works OK.  So that could be a workaround instead of creating
the folder in the filter editor.
(Reporter)

Comment 4

14 years ago
Still this defeats the purpose of IMAP, the purpose of IMAP is to keep the mail
on the server. So if I create the folder it still has to be created on the LOCAL
computer. I think it would be better to just filter in .msf files, so only
filtering where the headers are shown, and not OFFLINING the mail.


Monchi.
--

Comment 5

14 years ago
>So if I create the folder it still has to be created on the LOCAL computer.

No.  You can create folders on the IMAP server and select them as destination of
a filter.  Nothing except the .msf file is created on the local computer.
The mail is moved from INBOX to your folder by IMAP command, not via the local
system.
Of course you must select the correct folder in the filter.
(Reporter)

Comment 6

14 years ago
You are right, IMAPD is the culprit here. I could have known this earlier, with
a simple lsof. But then again imapd has a serious flaw in my eyes, but that
belongs in an other mailing list ;-)
Maybe it would be better for thunderbird to just move in header files in stead
of totaly being dependent on imap. And only for deleting to use imapd.

Comment 7

14 years ago
so this is invalid? As far as "relying on imap" is concerned, I prefer to think
of it as "supporting IMAP" :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.