bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

massport.com - Javascript ticker not displayed and no error - Serious information may be lost

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
--
minor
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Rajbabu Velmurugan, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Hello,

This is on 01/23/05. I was checking the Logan airport website for some
information (weather disruption caused problems). A ticker was showing that the
airport is closed....this did not show up in Firefox...but since I had IE I was
able to check it. There should be atleast an information / pop-up to say that
something did not work.

the site is:
http://www.massport.com/logan/

thanks

Reproducible: Always

Steps to Reproduce:
1. Go to: http://www.massport.com/logan/ (01/23/05 - 12.00 EST)
2. You can see 'News:' in red but no info next to it
3.

Comment 1

14 years ago
Server sends different content to IE with a DIV that animates this ticker:

[...]
<div id="rotLogan" class="Rotator2"
style="height:17px;width:226px;overflow:hidden;">
[...]

using Firefox, server doesn't the same HTML and it doesn't feature this ticker.

Not a Mozilla bug -> Tech Evangelism.
Assignee: firefox → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Hardware: PC → All
Summary: Javascript (or ASPX) ticker not displayed and no error - Serious information may be lost → massport.com - Javascript ticker not displayed and no error - Serious information may be lost

Comment 2

14 years ago
Created attachment 172173 [details]
Testcase

I am using a recent build of Camino, but I seem to be seeing the same as you.

There seems to be a big semantic problem here. If I understand you correctly,
the relevant part of the page is generated by this code:

<td valign="top" width="286">
  <img src="pic/p_news.gif" alt="News" border="0" height="20" width="48"> 
  <a href="http://www.massport.com/logan/airli.html" id="ancDownlevelRotator"> 

    <img 
      src="../tickerimage.aspx?site=logan&amp;almsg=&amp;msg=" 
      alt=" " 
      border="0" 
      height="20" 
      width="226"
    > 
  </a> 
  <img src="pic/p_centerline.gif" alt=" " border="0" height="20" width="12"> 
</td>

Now the URL that generates the 'ticker', 
http://www.massport.com/tickerimage.aspx?site=logan&almsg=&msg=
produces a small blue rectangle, so the render looks correct.

The alt=" " is of course a correct alternative for 'no news to report'.

At one level, Firefox is correctly conveying to you Logan's information 
that there is no news.

Interestingly, the <a> wrapped round the news 'ticker' takes you to
contact info for airlines, which would not seem to be a good match
for news in the sense of news of disruptions.

Are you really saying that this html is rendered differently in
other browsers?
(Reporter)

Comment 3

14 years ago
Thanks and Good to know about the fast repsonse to track issues.

Yes, it seems to work fine in Internet Explorer (which I rarely use). as of now,
the ticker is 'ticking' in IE...whereas in Firefox its 'static'.

looks like this is the offending line ....

<img SRC="pic/p_news.gif" WIDTH="48" HEIGHT="20" BORDER="0" ALT="News"><a
href="http://www.massport.com/logan/airli.html" id="ancDownlevelRotator"
border="0"><img
src="../tickerimage.aspx?site=logan&almsg=&msg=Logan+Airport+is+open+at+this+time.++Expect+delays."
alt=" Logan Airport is open at this time.  Expect delays." width="226"
height="20" border="0"></a><img SRC="pic/p_centerline.gif" WIDTH="12"
HEIGHT="20" BORDER="0" ALT=" "></td>
There is a ticker at the top and it's working now
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.